Download it now!
Bug 46804 - FORMATTING: Renaming a custom styles lost after saving/reloading of document
Summary: FORMATTING: Renaming a custom styles lost after saving/reloading of document
Status: CLOSED DUPLICATE of bug 38225
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 65941 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-29 22:04 UTC by nomnex
Modified: 2015-11-23 20:20 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nomnex 2012-02-29 22:04:09 UTC
I create custom styles for the shapes, connectors, drawing objects and text.

When I rename a style (eg. LOConnectorRed > LOConnectorRED1) all the objects connect to this style lose the style attribute (the objects revert to the default style).

I mainly use Draw for mid-complex flow-charts, I later embed in Writer documents.
Comment 1 sasha.libreoffice 2012-05-29 04:00:12 UTC
Thanks for bugreport
Please, attach document, produced after this:
> I create custom styles for the shapes, connectors, drawing objects and text.
but before this:
> When I rename a style (eg. LOConnectorRed > LOConnectorRED1)
Comment 2 QA Administrators 2013-05-27 16:54:36 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 3 sasha.libreoffice 2013-05-28 05:49:46 UTC
This bug in 4.0.3 is partially fixed. Now renaming of style works incorrectly.
Steps to reproduce:
0. Start Draw
1. Add new custom style (press F11 if needed)
2. Right mouse click it, "Modify", tab "Organizer", rename to LOConnectorRED1
(style now renamed)
Expected: correct saving/opening such file or warn about name is too long or disallow renaming of style or make field "name" more narrow or add restriction of length to it
Actually: style looks like renamed, but after saving/reloading changing disappears

3. save document
4. File->Reload

Changing title accordingly
Comment 4 QA Administrators 2015-03-04 02:19:26 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 5 Jean-Baptiste Faure 2015-03-09 05:50:13 UTC
Renaming a custom style seems still impossible.
Tested with LibreOffice 4.4.2.0.0+

Best regards. JBF
Comment 6 nomnex 2015-03-09 13:05:47 UTC
This bug affects both and Draw and Impress. Libreoffice 4.4.0.3. Thanks.
Comment 7 Buovjaga 2015-04-22 14:23:36 UTC
*** Bug 65941 has been marked as a duplicate of this bug. ***
Comment 8 Cor Nouws 2015-04-22 14:57:35 UTC
conform https://bugs.documentfoundation.org/show_bug.cgi?id=65941#c3 this is inherited from OOo
Comment 9 Regina Henschel 2015-11-23 20:19:48 UTC

*** This bug has been marked as a duplicate of bug 38225 ***