Bug 38225 - Unable to change name of a custom style
Summary: Unable to change name of a custom style
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.2.0 target:6.1.0.1 target:6.0.5
Keywords: easyHack
: 46804 71469 101323 113046 117488 (view as bug list)
Depends on:
Blocks: ImpressDraw-Styles
  Show dependency treegraph
 
Reported: 2011-06-13 00:59 UTC by Laurent BP
Modified: 2018-06-23 10:59 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2011-06-13 00:59:15 UTC
Hello,

To reproduce:
- create a new Draw document
- create an object
- create a new style from this object with "New style from selection", name "test"
- change name of style "test" to "test2" with right click on style > Modify
- save the file
=> OK, the name is correctly displayed
- File > Reload
=> style's name come back to "test"

Tested on WinXP (confirmed once).

There is no pb if you create style with right click in stylist > New.
It is only changing name which is "forget". Other change of format are correctly saved.
Comment 1 vitriol 2011-06-13 01:11:22 UTC
Confirmed in version 3.4.0 final too. New name is lost during save/reopen.
Comment 2 Björn Michaelsen 2011-12-23 12:20:50 UTC Comment hidden (obsolete)
Comment 3 Laurent BP 2011-12-27 00:01:27 UTC
Hello,

I can reproduce the bug with LibO 3.5b2
Comment 4 Laurent BP 2013-08-21 16:29:23 UTC
Confirmed with LibO Version: 4.2.0.0.alpha0+
Build ID: 6571193609f4fb4e5ac714b55787d172a86983f
on OpenSuse 12.3
Comment 5 Laurent BP 2014-04-08 09:00:46 UTC
Confirmed with:
- Version: 4.2.3.3
Build ID: 6c3586f855673fa6a1576797f575b31ac6fa0ba3
- Version: 4.3.0.0.alpha0+
Build ID: 003a27a14d5cf65fe0b528b6d6015e37a64dbb8e
TinderBox: Win-x86@39, Branch:master, Time: 2014-03-26_02:40:16

Creating a style with "New style from selection" will prevent renaming all custom styles, whatever the way they were created ("New style from selection" or > New from stylist)
Comment 6 Regina Henschel 2015-11-23 20:19:48 UTC
*** Bug 46804 has been marked as a duplicate of this bug. ***
Comment 7 Regina Henschel 2015-11-23 20:20:20 UTC
*** Bug 71469 has been marked as a duplicate of this bug. ***
Comment 8 burcin 2016-02-02 15:05:52 UTC
Hi, 
I want to work on this bug. I know Draw is in the sd directory. Which files in sd should I look for this bug ?
Comment 9 QA Administrators 2017-09-01 11:15:11 UTC Comment hidden (obsolete)
Comment 10 Thomas Lendo 2017-09-04 20:04:05 UTC
Still repro.

Version: 6.0.0.0.alpha0+
Build ID: bfd8a4e22fe584939f67b64c9c9495a466b16576
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-08-21_00:52:56
Locale: de-DE (de_DE.UTF-8); Calc: group
Comment 11 Mike Kaganski 2018-05-08 04:40:30 UTC
A code pointer: fix for bug 44774.
Comment 12 Xisco Faulí 2018-05-08 11:33:47 UTC
*** Bug 101323 has been marked as a duplicate of this bug. ***
Comment 13 Mike Kaganski 2018-05-27 10:42:07 UTC
*** Bug 117488 has been marked as a duplicate of this bug. ***
Comment 14 Mike Kaganski 2018-05-27 11:05:53 UTC
https://gerrit.libreoffice.org/54879
Comment 15 Commit Notification 2018-05-27 16:32:07 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8a648b82f85d4b0eed67067ed2ddc211ad64ce72

tdf#38225: update API name when renaming using a base class ref

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Mike Kaganski 2018-05-27 17:03:51 UTC
Awaiting:
https://gerrit.libreoffice.org/54887 for 6.1,
https://gerrit.libreoffice.org/54890 for 6.0.
Comment 17 Commit Notification 2018-05-28 04:31:17 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=da49f4aeb8d5e9a7d2cba8855d911e7cc1d2f1e2&h=libreoffice-6-1

tdf#38225: update API name when renaming using a base class ref

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2018-05-31 09:01:40 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9c508e87be1f8fa252a9c6ffdb82a977be070143&h=libreoffice-6-0

tdf#38225: update API name when renaming using a base class ref

It will be available in 6.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 kompilainenn 2018-06-23 10:59:46 UTC
*** Bug 113046 has been marked as a duplicate of this bug. ***