Download it now!
Bug 71469 - Custom styles cannot be renamed
Summary: Custom styles cannot be renamed
Status: CLOSED DUPLICATE of bug 38225
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-11 08:30 UTC by Markus Michels
Modified: 2015-11-23 20:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Michels 2013-11-11 08:30:47 UTC
Second bug indicating that LO 4xy formatting is very broken.

Custom styles cannot be renamed.

Steps to reproduce:
Open impress, create new document
Add a shape (e.g. rectangle) to page
Open styles menu (hit F11)
Select rectangle
Click in styles menu "new style from selection"
Name it "watchamacallit"
Change the style settings (e.g. other background i.e. area color)
Save the document, close impress, re-open document - everything fine so far
Hit F11 again, select custom style "watchamacallit", right click and select edit
Go to "organizer" tab and change name to "nowwithaname"
Save, close impress and re-open the document
Custom style is called "watchamacallit" again, "nowwithaname" disappeared

So once created styles will reside with given name forever in the document. Expected behavior would be that changes to style names persist.
Comment 1 Jean-Baptiste Faure 2013-11-11 11:06:33 UTC
I reproduce the problem with LibreOffice 4.1.4.0.0+ under Ubuntu 13.10 x86-64
The bug seems specific to Impress, indeed I do not have it with Writer.

Best regards. JBF
Comment 2 Markus Michels 2013-11-29 13:18:21 UTC
Bug still exists in LO 4.2.0 Beta 1 Linux x64
Comment 3 QA Administrators 2015-04-19 03:21:06 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 4 Jean-Baptiste Faure 2015-04-25 21:51:07 UTC
Still reproducible with LibreOffice 5.0.0.0.alpha1+ built at home under Ubuntu 14.10 x86-64

Best regards. JBF
Comment 5 Regina Henschel 2015-11-23 20:20:20 UTC

*** This bug has been marked as a duplicate of bug 38225 ***