Download it now!
Bug 46823 - EDITING: Misspelled word with various direct formatting applied to it isnt preserved when corrected
Summary: EDITING: Misspelled word with various direct formatting applied to it isnt pr...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: lowest trivial
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Spell-Checking Formatting-Text-Diverse
  Show dependency treegraph
 
Reported: 2012-03-01 05:53 UTC by Leandro
Modified: 2020-09-04 20:40 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leandro 2012-03-01 05:53:17 UTC
Problem description: BOLD automatically lost

Steps to reproduce:

1. click the right mouse button directly on the text marked for correction (underlined in red) in bold letters, and accept any suggestions. The word will change, but will lose the bold.

Current behavior:

The word will change, but will lose the bold.

Expected behavior:

The word will change, but must continue with the bold.

Platform (if different from the browser): 

Windows 7, Libreoffice 3.5.1.1 RC1
              
Browser: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.56 Safari/535.11
Comment 1 Jose Manuel 2012-04-20 12:47:40 UTC
[Not Reproducible] with "LibreOffice 3.3.4 - Ubuntu 11.04 (32bit) Spanish UI"
Comment 2 Javier Catalá 2012-04-21 08:43:57 UTC
[Not reproducible] with "LibreOffice 3.5.2 - Windows Vista Home Premium (32bit) Spanish UI"
Comment 3 sasha.libreoffice 2012-05-29 04:39:41 UTC
Thanks for bugreport
reproduced in 3.3.4 and 3.5.3 on Fedora 64 bit, but only if part of word is bold, or after word is punctuation mark.
Steps to reproduce:
0. Start Writer and change language of document to English
1. Enter asdf.
2. Select asdf and make it bold (select without dot at end)
3. right mouse click, select proposed variant
Expected: Word remains bold
Actually: Word becomes non-bold
This happens because Writer determines character attributes by last character in word. But in this case last character is dot. And it is not bold.
Comment 4 Yousuf Philips (jay) (retired) 2014-06-25 02:11:51 UTC
Confirmed using comment 3 that its still present in 4.3.0 and is there also in 3.3.0.
Comment 5 Radu 2015-04-04 16:16:07 UTC
Still present in : 4.5.0.0.alpha0+
Comment 6 tommy27 2016-04-16 07:26:45 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-05-22 13:22:48 UTC Comment hidden (obsolete)
Comment 8 Yousuf Philips (jay) (retired) 2017-06-09 21:01:23 UTC
Still present. So basically it uses the formatting applied to the left letter of the mispelled word and applies it to the entire word. This happens both in the context menu and the spelling dialog.

Version: 5.5.0.0.alpha0+
Build ID: ddf8539d97ce044b7df8d51d6ec72ec864b40fb8
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-06-04_22:10:59
Locale: en-US (en_US.UTF-8); Calc: group
Comment 9 QA Administrators 2018-06-11 02:34:34 UTC Comment hidden (obsolete)
Comment 10 QA Administrators 2020-06-11 03:53:17 UTC Comment hidden (obsolete)
Comment 11 Telesto 2020-09-04 11:17:15 UTC
This should be solved, i think
Version: 7.1.0.0.alpha0+ (x64)
Build ID: e8b8e7be0b2ad693224cd94062a55610eb69df7e
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 12 Thomas Lendo 2020-09-04 20:32:49 UTC
Version: 7.1.0.0.alpha0+
Build ID: 0d2dbcbebf0004e690feb91c38dd478a32dc6255
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: de-DE (de_DE.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-08-30_17:39:21
Calc: threaded

Seems to be solved by the patch that solved many of the bugs of META bug 127250.

Closing as RESOLVED WORKSFORME.

Wohoo!
Comment 13 Telesto 2020-09-04 20:40:42 UTC
(In reply to Thomas Lendo from comment #12)
> Version: 7.1.0.0.alpha0+
> Build ID: 0d2dbcbebf0004e690feb91c38dd478a32dc6255
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
> Locale: de-DE (de_DE.UTF-8); UI: en-US
> TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
> 2020-08-30_17:39:21
> Calc: threaded
> 
> Seems to be solved by the patch that solved many of the bugs of META bug
> 127250.
> 
> Closing as RESOLVED WORKSFORME.
> 
> Wohoo!

Congratulations ;-). You accidentally fixed quite a number of bug