Download it now!
Bug 46842 - Corrupted enummeration in RTF format
Summary: Corrupted enummeration in RTF format
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:rtf
Depends on: 40977
Blocks: RTF
  Show dependency treegraph
 
Reported: 2012-03-01 11:56 UTC by Ulf Zibis
Modified: 2018-02-04 21:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Corrupted RTF (13.21 KB, application/rtf)
2012-03-01 11:56 UTC, Ulf Zibis
Details
Original ODT (18.06 KB, application/vnd.oasis.opendocument.text)
2012-03-01 11:58 UTC, Ulf Zibis
Details
screen shot (16.83 KB, image/png)
2012-03-02 06:47 UTC, Ulf Zibis
Details
ODT where wrong negative indentation was removed (10.82 KB, application/vnd.oasis.opendocument.text)
2012-03-24 03:36 UTC, Ulf Zibis
Details
RTF export with LO 6.0 (13.28 KB, application/rtf)
2018-02-04 21:21 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ulf Zibis 2012-03-01 11:56:36 UTC
Created attachment 57872 [details]
Corrupted RTF

I have saved an odt document as rtf document.
Compare the attached files.
Comment 1 Ulf Zibis 2012-03-01 11:58:48 UTC
Created attachment 57873 [details]
Original ODT
Comment 2 Ulf Zibis 2012-03-01 12:00:57 UTC
There is dataloss, if one creates a new document with enumerations used, and only saves the document in RTF format.
Comment 3 s-joyemusequna 2012-03-02 04:42:32 UTC
Confirmed with LibO 3.3.4, 3.4.5, and 3.5.1 Beta1 on Windows XP.

There is no data loss, but the tabulators are misplaced starting with the paragraph "Fachliche Kompetenzen ..."
Comment 4 Ulf Zibis 2012-03-02 06:47:25 UTC
Created attachment 57918 [details]
screen shot

(In reply to comment #3)
> There is no data loss,

In my understanding, formatting is also data.

> but the tabulators are misplaced starting with the
> paragraph "Fachliche Kompetenzen ..."

There are more errors, see my screen shot.
Comment 5 Jean-Baptiste Faure 2012-03-22 05:39:17 UTC
I see two problems with the import of this RTF file :
1/ titles without numbering -> 0 is added in front of the line
2/ RTF filter seems to not accept negative first line indent.

Side note : if you consider formatting as data, there is nothing in a document that is not data and the keyword dataloss becomes useless.
In this case, no text fragment has been lost in the RTF export, so no data loss.

Miklos : this one is for you. Please feel free to reassign if you can't handle this bug.

Best regards. JBF
Comment 6 Jean-Baptiste Faure 2012-03-22 05:41:39 UTC
Sorry, forgot to mention that I reproduce the problem with LO 3.5.3 rc0+ and master (LibreOffice 3.6.0alpha0+ Build ID: 08ba87c-49d3d39-e67b1bf-879ce36-638d9c) under Ubuntu 11.10 x86_64.
So I set platform and OS accordingly
Comment 7 Ulf Zibis 2012-03-24 03:36:27 UTC
Created attachment 58963 [details]
ODT where wrong negative indentation was removed

- Save it as RTF
- Reopen the RTF
- Compare and wonder ;-)
Comment 8 Jean-Baptiste Faure 2012-03-25 07:45:41 UTC
(In reply to comment #7)
> Created attachment 58963 [details]
> ODT where wrong negative indentation was removed
> 
> - Save it as RTF
> - Reopen the RTF
> - Compare and wonder ;-)

Ok, so the problem of titles without numbering is not an import problem but is an export problem. If I save the ODT to RTF with Abiword and open this RTF with LO 3.5.2 rc1 the title level 1 is correct.

Best regards. JBF
Comment 9 Ulf Zibis 2012-03-28 14:26:50 UTC
Another RTF problem:
Bug 48013 - German Umlaute lost on copy via clipboard from RTF
Comment 10 Jean-Baptiste Faure 2012-05-14 21:56:41 UTC
Title numbering has been solved by Miklos in bug 49692.
Problem remaining in the present case : tab stops are different in rtf file as they are in odt file.

Best regards. JBF
Comment 11 Alexandr 2014-07-16 11:35:15 UTC
I reproduce the issue with tabs with LibreOffice 4.2.5 and 4.3.0.2 on Debian x86_64. Distances between characters and lines are slightly different in odt and rtf.
Comment 12 QA Administrators 2015-09-04 02:50:01 UTC Comment hidden (obsolete)
Comment 13 Jean-Baptiste Faure 2015-09-05 15:45:17 UTC
Tab stops problem still reproducible with LibreOffice 5.0.3.0+.

Best regards. JBF
Comment 14 Robinson Tryon (qubit) 2015-12-10 01:08:30 UTC Comment hidden (obsolete)
Comment 15 Miklos Vajna 2015-12-22 22:09:33 UTC
Reset Assignee to default till I actually start looking into this.
Comment 16 QA Administrators 2017-01-03 19:58:05 UTC Comment hidden (obsolete)
Comment 17 Jean-Baptiste Faure 2017-02-01 05:34:46 UTC
Tab stops problem still reproducible in LO 5.3.1.0.0+
Version: 5.3.1.0.0+
Build ID: d9423d80e7a2c8dc323027425780a17e76b6d0c6
Threads CPU : 4; Version de l'OS :Linux 4.4; UI Render : par défaut; VCL : gtk3; Moteur de mise en page : nouveau; 
Ubuntu_16.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: group

Best regards. JBF
Comment 18 QA Administrators 2018-02-02 03:36:37 UTC Comment hidden (obsolete)
Comment 19 Jean-Baptiste Faure 2018-02-04 21:21:03 UTC
Created attachment 139585 [details]
RTF export with LO 6.0

Not reproducible anymore for me with LibreOffice 6.0.1.0+ built at home under Ubuntu 16.04 x86-64.

Setting status as WorksForMe. Please feel free to reopen if you disagree.

Best regards. JBF