Bug Hunting Session
Bug 46868 - Calc functionality request [FORMATTING]: Add option of anchoring for resizing a line should not resize anchored images
Summary: Calc functionality request [FORMATTING]: Add option of anchoring for resizing...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL: http://science.rehoboth.on.ca/Genetic...
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Images
  Show dependency treegraph
 
Reported: 2012-03-02 00:52 UTC by Nicolas Mailhot
Modified: 2018-03-06 14:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Mailhot 2012-03-02 00:52:44 UTC
When one anchors an image in a cell, one does not expect this image size to change when the line height is changed.

However calc will distort images whenever the user selects all cells and ask to resize line heights to see hidden text (I know one can fix the image size but 1. this is not the default and 2. it also inhibits resizing the image via mouse controls. Cell line height should not change inserted images at all)
Comment 1 sasha.libreoffice 2012-05-29 07:17:02 UTC
Thanks for bugreport
It is not a bug. So should be. If object anchored co cell, then is resizes automatically.

Exaple: draw arrow from A1 to C3, change anchoring to cell. Then change size of column B. Arrow still points to cell C3.

Change anchoring to page for disable autoresizing of object
Comment 2 sasha.libreoffice 2012-08-08 05:54:16 UTC
But msExcel has 3-th option of anchoring. Something like "Anchor to cell but not resize with cells".
Comment 3 hsikkema 2016-10-26 21:54:23 UTC
If anchored to page, when rows are added or changed in height the object do not move accordingly so that is not a good solution. 

Secondly, why should anchor to cell cause size change upon saving the file? 

Third, all object on the page are anchored to cell but only three are affected by saving and re-opening the file.

Something must be wrong with the coding of object placement.
Comment 4 Samuel Mehrbrodt (CIB) 2018-03-06 14:53:19 UTC
It's now possible to anchor images to cell without resizing them with the cell:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=acf0bad4e2b8c3c43aaaee8312c8a61d3552fcc2