Bug 48123 - FILEOPEN: Anchors do not keep setting to value "To Cell" with an xls file.
Summary: FILEOPEN: Anchors do not keep setting to value "To Cell" with an xls file.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-31 08:07 UTC by Dan
Modified: 2015-02-26 12:14 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
ODS with picture anchored to cell (31.89 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-06-27 02:13 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan 2012-03-31 08:07:56 UTC
Steps to reproduce:
1. Create a new spreadsheet document.
2. Copy and paste an image into a cell.
3. Set Anchor : "To Cell".
4. First save the document with extension .ods
5. Then save the document with extension .xls
6. Close the documents.

Current behavior:
Unlike ".ods" document, when i open the document ".xls", Anchors do not keep setting to value "To Cell".

In consequence: when inserting a line or column before the picture, it does NOT remain in the cell associated.

Platform (if different from the browser): Windows XP
            
Browser: Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 1 sasha.libreoffice 2012-06-27 02:13:46 UTC
Created attachment 63505 [details]
ODS with picture anchored to cell
Comment 2 sasha.libreoffice 2012-06-27 02:26:06 UTC
Thanks for bugreport
reproduced in 3.3.4, 3.5.4, 3.6.beta1 on Fedora 64 bit
Changing version to 3.3.4 as most early reproduced

It looks like saving to xls format performs correctly. (Excel opens it correctly anchored) Problem is with opening.

What is interesting:
msExcel have 3 variant of anchoring:
1. not move with cell
2. move with cell, but not resize
3. move and resize with cell
Calc have only 1 and 3 variant. May be problem with mapping Excel anchoring to Calc anchoring.
Comment 3 p_kongstad 2012-11-28 18:49:10 UTC
Hi, I can confirm this behavior as well in 3.6.2.
Comment 4 ZĂ© Silva 2012-12-01 18:18:53 UTC
Hi, I confirm this same behavior in version 3.6.3.2 (58f22d5).
Comment 5 Cor Nouws 2014-06-12 17:43:10 UTC
*** Bug 79937 has been marked as a duplicate of this bug. ***
Comment 6 Matthew Francis 2015-02-16 08:14:12 UTC
*** Bug 89289 has been marked as a duplicate of this bug. ***
Comment 7 Timur 2015-02-16 13:09:00 UTC
I don't see how Bug 89289 is a duplicate of Bug 48123. 
Bug 89289 is about proper picture preview during "Optimal row hight" with anchor "To Cell", both for setting in LO or opening xls(x). 
Bug 48123 is about keeping anchor "To Cell" when saving as XLS. And it seems resolved, please test and mark as WFM.
Comment 8 Timur 2015-02-26 12:14:39 UTC
Seems like fixed somewhere in 3.6.x.
Since no further comments, I close as WFM. 
Please reopen if further tests show the opposite.