Bug 46885 - LibO crash when creating chart with no cells selected
Summary: LibO crash when creating chart with no cells selected
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.5.1 RC1
Hardware: x86 (IA32) All
: medium critical
Assignee: Markus Mohrhard
QA Contact:
URL:
Whiteboard: target:3.6.0 target:3.5.1
Keywords:
: 47088 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-02 03:49 UTC by Leif Lodahl
Modified: 2012-03-08 00:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leif Lodahl 2012-03-02 03:49:36 UTC
When you start a new chart and have one empty cell selected LibO will crash when you select the Next>> button.
If you select multiple empty cells and then start a new chart LibO will crash immediately.

Ubuntu Linux
Comment 1 Leif Lodahl 2012-03-02 04:10:08 UTC
Same problem on Windows XP. On Windows I see an error message. "Because of an unexpected error..."
Comment 2 Not Assigned 2012-03-04 08:21:51 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6ba126ce26c83a0e6766e8dc8c38202d2a2ab238

don't crash for empty input data in charts, fdo#46885
Comment 4 vitriol 2012-03-08 00:26:41 UTC
*** Bug 47088 has been marked as a duplicate of this bug. ***