Bug 46917 - FORMATTING: Inserted 'Tables' in presentation respond poorly for configuration changes
Summary: FORMATTING: Inserted 'Tables' in presentation respond poorly for configuratio...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
Whiteboard: BSA
: 75684 (view as bug list)
Depends on:
Blocks: ImpressDraw-Tables
  Show dependency treegraph
Reported: 2012-03-02 21:00 UTC by pharmankur
Modified: 2020-09-29 07:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

Presentation showing common issues with Table in Impress (1.08 MB, application/vnd.oasis.opendocument.presentation)
2014-08-20 07:53 UTC, pharmankur

Note You need to log in before you can comment on or make changes to this bug.
Description pharmankur 2012-03-02 21:00:38 UTC
Problem description & Steps to reproduce :

When we insert & try to edit 'Table' in presentation, in general it responds poorly to the edits. [like colour formatting, font changes in the table text, colour & thickness changes of table borders etc.)

i.e. even when I select config (e.g. say - font Arial size 32 colour red; table borderline black coloured 1.00 thick ; colour background invisible  etc.) this config do not show up in table instantly.

Many of the times borders of  a table disappears when the presentation is closed & opened again. 

This issue is more serious in Linux / Ubuntu ; but to my surprise, same version (3.5.0) run & respond to table config changes far superior under windows XP.

Current behavior: Config settings changes in table option do not show up effects

Expected behavior: whatever change we make should instantly reflect in selected table

Platform (if different from the browser): Ubuntu 11.10
Browser: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Comment 1 sasha.libreoffice 2012-03-23 06:15:29 UTC
Thanks for bugreport
Please, verify if in last version of LibreOffice still reproducible
(3.5.1 or more recent if available)
Comment 2 pharmankur 2012-03-23 07:17:18 UTC
Its very much present even in LO 3.5.1 ...
there in no improvement on that front ... also in Calc the borders do not behave well ... very irritating.
Comment 3 sasha.libreoffice 2012-03-23 08:58:34 UTC
Thanks for additional testing.
Sorry for I can not reproduce slow table update in 3.5.1 on Fedora and Windows
Please, try move LibreOffice in another place and see if problem still remains.
Also, try on another computer/OS/desktop if available
Comment 4 bfoman (inactive) 2012-08-08 09:49:07 UTC
Confirmed with:
Build ID: own W7 debug build
Windows 7 Professional SP1 64 bit

Created 6x20 table and every operation like changing text style, align, font size, color, resizing, moving is quite delayed. From x to xx seconds.
Comment 5 sasha.libreoffice 2012-08-08 10:07:50 UTC
Thanks for additional information. Sorry for not understand problem from first attempt.
Indeed table 6x20 is very slow if we try to move it, resize, change "Table design" on right hand pane. But if we input text into table, it updates immediately. 
Reproduced in 3.3.4, 3.5.5, 3.6.0rc on Fedora 64 bit
Changing version to 3.3.4 as most early reproduced
Comment 6 pharmankur 2014-08-20 07:53:31 UTC
Created attachment 104963 [details]
Presentation showing common issues with Table in Impress
Comment 7 pharmankur 2014-08-20 07:55:29 UTC
Also while making this presentation I encountered a issue with 'Vanishing of inserted images' in Impress described as issue no 5 in presentation. 

Rest 4 issues are related to Table properties.
Comment 8 pharmankur 2014-08-20 07:57:09 UTC
created with Libreoffice 4.3.0
Comment 9 Jean-Baptiste Faure 2015-05-07 04:41:07 UTC
*** Bug 75684 has been marked as a duplicate of this bug. ***
Comment 10 QA Administrators 2016-09-20 09:37:21 UTC Comment hidden (obsolete)
Comment 11 pharmankur 2016-09-20 13:19:46 UTC
Dear QA team,

I have tested the issue on Linux Mint 18 (64 bit) with LO version ,
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default;

And my observations are ...

Most of the issues mention in previously enclosed bug report presentation 'SEEM' resolved ... only untill table is small e.g 5 X 3.

But the situation is worse when table grows up in size. I created a table of 20 X 20 & tried to apply possible editing as mentioned in my bug report ... and I found
if you try to change even boarder colour of big table (I tried with 20 X 20), Libreoffice freezes and I have to XKILL it.

No edit is possible on bigger tables. Thus for me the issue / bug prevails.

Hope after this retesting the issue will be at least marked as confirmed & will be assigned to someone.

But thanks anyways for asking me to test, If you want any further assistance I will be glad to help !

Ankur Joshi
Comment 12 jose.velez 2017-02-04 06:49:14 UTC
The bug is still present in Impress 5.3.X and 5.2.X

1) Create a 5x5 table.
2) Select first row.
3) Use Right click to go to "Table Property" panel.
4) Change border color
5) Press ok button

There are no changes in the borders of the first row of the table.
Comment 13 QA Administrators 2019-02-02 03:43:47 UTC Comment hidden (obsolete)
Comment 14 pharmankur 2020-09-29 07:11:00 UTC
Issue is not resolved and continued as it was before. Tested with LO 7.0.1