Bug 46918 - CONFIGURATION: MS Excel Function compatibility with LO Calc
Summary: CONFIGURATION: MS Excel Function compatibility with LO Calc
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Calc-Function
  Show dependency treegraph
 
Reported: 2012-03-02 21:32 UTC by pharmankur
Modified: 2017-07-13 19:34 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Head to head comparison list of spreadsheet functions, availability & support in EXCEL Vs Calc (23.63 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-03-02 21:32 UTC, pharmankur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pharmankur 2012-03-02 21:32:05 UTC
Created attachment 57953 [details]
Head to head comparison list of spreadsheet functions, availability & support in EXCEL Vs Calc

Problem description: 

Excel 2007 Function compatibility with LO Calc ...

In order to improve acceptance of LO Calc, It should emphasis on adding up all the functions which Excel 2007 / 2010 are providing. In many versions of OOo or LO , this issue is not addressed well.

There are many useful functions like 'IFERROR' are present in Excel 2007 which are not supported by LO Calc. The formula's made by using these functions do not operate with LO & gives error. It hinders to use LO in large scale.

As spreadsheets are the most used feature of any office suite, if LO wants to deliver a professional grade product; LO Calc MUST support ALL the functions in MS office 2007/10.
I have made an head to head comparison list of spreadsheet functions availability & support in EXCEL Vs Calc.
find the comparison file attached ---

Hope developers find it useful to quickly bridge the gap between.


Current behavior: MS Office spreadsheet formulas do not work (100%) in Calc

Expected behavior: Calc should open all formlae in which are present in MS excel

Platform (if different from the browser): Ubuntu 11.10
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Comment 1 Joel Madero 2012-07-11 22:48:58 UTC
I'm hesitant to prioritize this one as is because of how all encompassing it is. Personally I feel like this is better addressed individually (per function) instead of all encompassing. This way we get an idea of the useful functions and don't spend time implementing functions that aren't being used (or barely being used). 

Any opinions about this? I think that the IFERROR since it was specifically mentioned can be turned into it's own request. We may be able to make a meta-bug similar to the annoying bugs meta bug that has links to every function currently not implemented but that is desired by our user base.

Open to suggestions :)
Comment 2 Joel Madero 2012-07-13 15:58:32 UTC
I am marking this as INVALID because it is really a lot of requests bundled up into one. We've had an internal discussion between devs and QA and decided to move this to the wiki (which I will do), then we can prioritize the functions and hopefully get the most important ones implemented and leave the not so important ones alone unless specifically requested.

If there are specific functions that you (or any other user) really feel is missing and important please open a specific bug for that function so that we can try to get a grasp on what functions are really desired by the community. We had discussed opening a bug for each function that you list in your spreadsheet but decided against this as it doesn't help at all with prioritizing or getting a sense of what users want & might end up resulting in bugs just sitting on the list for months or years with no one commenting and no dev picking it up.

Thanks for getting the list together, it'll help a lot. I'll link to the wiki once I get it on there
Comment 3 pharmankur 2012-07-17 07:20:07 UTC
well ... doing something is better than nothing!
I hope we will get full set of functions to work in Calc flawlessly.
Comment 4 pharmankur 2012-07-17 07:43:03 UTC
A though just came in about knowing & prioritizing the functions ...
Firstly I feel we should try to incorporate "all" functions , may be not at once but gradually adding few with every release of LO.
The reason I am asking for 'ALL' functions because that's what will make LO fully compatible. Also we never know when we require which function .. No function is non-essential but its totally upon the need which requires certain functions for that time.

If we want to priorities the functions & know which are the most used ones, you can create function wise poll for missing functions from LO (asking users which of the functions you know / use)  & post it on not just LO community but also on MS office communities on social network sites.

There you my get quick & wide feedback.
Comment 5 Joel Madero 2012-07-17 15:58:09 UTC
I personally am not going to go to Microsoft forum to ask....if you want to feel free to and you can report back on the wiki:

https://wiki.documentfoundation.org/Development/Calc/Spreadsheet_Functions#List_of_Microsoft_Excel_Functions_Currently_Not_Supported_in_LO

As for a voting method from us, from what I've seen, it's been tried once as an unofficial thing and I didn't particularly like it. But what I did was include a table on the wiki I've linked to that you can "vote" by just increasing the # by 1. This is not the prettiest method but it's a start.

a) Complete wiki that I created, I only go through part of the list so far. Your list was good but I found some inconsistencies/errors so I'm testing every function from Excel just to confirm each one. This is necessary regardless and your list is still really useful (many thanks)

b) If you end up creating a forum on Microsoft forum and you see a particular function(s) that are "most desired" please leave a comment where appropriate on the wiki. That would help tremendously.

I think that's all, again really appreciate this. We have a mixed bag of opinions if we're going to implement every single function but we'll try to get to the most desired ones as fast as possible. Organizing is a mandatory first step :)
Comment 6 pharmankur 2013-01-25 17:32:22 UTC
Just I read release notes for LO 4.0. 
https://wiki.documentfoundation.org/ReleaseNotes/4.0

As per that new functions includes--
"
New spreadsheet functions AVERAGEIF, SUMIFS, AVERAGEIFS and COUNTIFS as defined in ODF OpenFormula. fdo#41214 (Marina Plakalovic, Daniel Rentz, Eike Rathke)

    New spreadsheet functions IFERROR and IFNA as defined in ODF OpenFormula. fdo#56124 (Winfried Donkers, Eike Rathke)
"

If thats true kindly update 
https://wiki.documentfoundation.org/Development/Calc/Spreadsheet_Functions#List_of_Microsoft_Excel_Functions_Currently_Not_Supported_in_LO