Download it now!
Bug 46957 - FILEOPEN: Text Wrap not correctly displayed when opening Excel XP format saved in OO 3.4
Summary: FILEOPEN: Text Wrap not correctly displayed when opening Excel XP format save...
Status: CLOSED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 47258 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-04 07:49 UTC by Jeff Evans
Modified: 2015-11-18 12:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
List of cheques issued. Multiple examples in column E. (14.50 KB, application/vnd.ms-excel)
2012-06-02 02:07 UTC, Jeff Evans
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Evans 2012-03-04 07:49:29 UTC
Problem description: When opening a spreadsheet save in Excel XP format by OO 3.4 with automatic text wrap on some columns, the text is displayed on one line without wrapping.

Problem can be cured by entering "Format Cells" Panel and just pressing "OK".

Problem does not occur with files saved by LibO 3.5. Not checked for files saved by other software.


Steps to reproduce:
Open an Excel XP format spreadsheet with wrapped text saved in OpenOffice 3.4.

Current behavior:
On initial opening, cells with wrapped text displayed as single line with continuation indicator. Display is corrected by entering "Format Cells" menu and just pressing "OK" 

Expected behavior:
Cells should be displayed in wrapped format from the start.

Platform (if different from the browser): 
              
Windows XP SP3.
Comment 1 sasha.libreoffice 2012-05-30 04:16:48 UTC
Thanks for bugreport
Please, attach document that demonstrates this problem
Comment 2 Jeff Evans 2012-06-02 02:07:30 UTC
Created attachment 62412 [details]
List of cheques issued. Multiple examples in column E.

Problem file attached. Previous description not totally accurate; prolem solved by entering "Alignment" tab of "Format Cells".

Still on version 3.5.2.2 due to another bug in 3.5.3.
Comment 3 sasha.libreoffice 2012-06-03 23:46:37 UTC
Thanks for attachment
reproduced in 3.3.4 and 3.5.4 on Fedora 64 bit (Windows not tested)
Changing version to 3.3.4 as most early reproduced
Comment 4 Teo91 2013-09-30 12:51:01 UTC
I can confirm this with LO 4.1.1 on Windows 7 SP1.
Comment 5 Owen Genat (retired) 2014-08-12 03:05:39 UTC
*** Bug 47258 has been marked as a duplicate of this bug. ***
Comment 6 QA Administrators 2015-09-04 02:48:18 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.0.5 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-09-03
Comment 7 Buovjaga 2015-11-18 12:10:02 UTC
Still confirmed, but I wonder, if we should care for a bug originating in 3.4?

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: b216cc1b8096eb60c27f67e8c27b7cd756c75e38
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-12_00:06:20
Locale: fi-FI (fi_FI)
Comment 8 Eike Rathke 2015-11-18 12:38:53 UTC
There isn't much we can do. Apparently the old version didn't save the resulting row heights, it saved custom but explicitly set them to the default value instead, so when loading the document each row has the same height.