Bug 46967 - RTF lists don't inherit style of their paragraph (leveltext doesn't scale bullet point with font size)
Summary: RTF lists don't inherit style of their paragraph (leveltext doesn't scale bul...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:rtf
Depends on:
Blocks: RTF-Bullet-Number-Lists
  Show dependency treegraph
 
Reported: 2012-03-04 13:04 UTC by soren.hein
Modified: 2022-01-25 11:56 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The example file in Word and Writer master (117.02 KB, image/png)
2022-01-25 11:54 UTC, Gabor Kelemen (allotropia)
Details
The example file (385 bytes, application/msword)
2022-01-25 11:55 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description soren.hein 2012-03-04 13:04:22 UTC
In the below file, the "x" that is used as a bullet point does not come out in \fs18 font size.  This also leads to a larger line spacing than desired.  You can see both effects if you open the file in Writer and mark all text as font size 9 points.

Microsoft Word does it in what I consider to be the right way.


{\rtf1\ansi\deff0\adeflang1025
{\fonttbl{\f0\fcharset0\fprq2 Arial;}}
{\*\listtable{\list\listtemplateid1
{\listlevel\levelnfc23\levelfollow0{\leveltext\'01x;}
{\levelnumbers;}}\listid1}}
{\*\listoverridetable{\listoverride\listid1\listoverridecount0\ls1}}
\f0\fs18
{Starting sentence\par}{\pard\ls1\fi-360\li360
{First point.\par}
{Second point.\par}
{Last point.\par}
}
}
Comment 1 s-joyemusequna 2012-03-19 09:23:21 UTC
Confirmed with LibO 3.5.1 on Windows XP. The size of the "x" is 12 points, should be probably 9 points (like with Word 2007).

Nevertheless a big enhancement : OOo 3.1, LibO 3.3.4, and LibO 3.4.5 don't display the "x" and the tabulators at all.
Comment 2 Jean-Baptiste Faure 2012-03-22 22:43:55 UTC
Miklos: please have a look.

Best regards. JBF
Comment 3 Miklos Vajna 2012-03-23 03:15:01 UTC
Reproduced. However this till take some time to fix - the RTF default is to take the character properties of the current paragraph in the leveltext ("x" in your example), however in Writer we always need a named character style in the list style at the moment.

That proably explains the test document in doc or docx format isn't imported correctly, either.
Comment 4 Roman Eisele 2012-05-31 06:09:31 UTC
This bug is not specific to MacOS X (see comment #1), therefore changed the Platform field to "All/All".
Comment 5 Robinson Tryon (qubit) 2015-12-10 01:08:20 UTC Comment hidden (obsolete)
Comment 6 Miklos Vajna 2015-12-22 22:07:08 UTC
Reset Assignee to default till I actually start looking into this.
Comment 7 QA Administrators 2017-01-03 19:57:34 UTC Comment hidden (obsolete)
Comment 8 soren.hein 2017-01-03 20:57:55 UTC
Still the same bug in 5.1.6.2 on Windows 10
Comment 9 QA Administrators 2018-10-06 02:49:45 UTC Comment hidden (obsolete)
Comment 10 soren.hein 2018-10-09 19:12:39 UTC
Still the same bug in 6.1.2.1 (x64) on Windows 10
Comment 11 QA Administrators 2019-10-10 02:40:28 UTC Comment hidden (obsolete)
Comment 12 soren.hein 2019-11-11 06:45:19 UTC
Still the same bug in 6.3.2.2 (x64) on Windows 10
Comment 13 QA Administrators 2021-11-11 04:14:54 UTC Comment hidden (obsolete)
Comment 14 Gabor Kelemen (allotropia) 2022-01-25 11:54:50 UTC
Created attachment 177770 [details]
The example file in Word and Writer master

This seems to be fixed recently with:

https://git.libreoffice.org/core/+/7b8ae6f90c37c18ff724c0751b5f73cca6ae02ac

author	Tünde Tóth <toth.tunde@nisz.hu>	Fri Nov 19 12:23:41 2021 +0100
committer	László Németh <nemeth@numbertext.org>	Mon Nov 29 10:54:39 2021 +0100

tdf#97899 DOCX import: allow character formatting only of numbering

Now the bullets are reported to be Arial 9pt like in Word, before they were TNR (or Liberation Serif) 12 pt.
Comment 15 Gabor Kelemen (allotropia) 2022-01-25 11:55:40 UTC
Created attachment 177771 [details]
The example file

Uploading for easier reference
Comment 16 Gabor Kelemen (allotropia) 2022-01-25 11:56:31 UTC
Thanks Tünde for making this one go :)