Bug 46967 - RTF lists don't inherit style of their paragraph (leveltext doesn't scale bullet point with font size)
Summary: RTF lists don't inherit style of their paragraph (leveltext doesn't scale bul...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:rtf
Depends on:
Blocks: RTF-Bullet-Number-Lists
  Show dependency treegraph
 
Reported: 2012-03-04 13:04 UTC by soren.hein
Modified: 2021-11-11 04:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description soren.hein 2012-03-04 13:04:22 UTC
In the below file, the "x" that is used as a bullet point does not come out in \fs18 font size.  This also leads to a larger line spacing than desired.  You can see both effects if you open the file in Writer and mark all text as font size 9 points.

Microsoft Word does it in what I consider to be the right way.


{\rtf1\ansi\deff0\adeflang1025
{\fonttbl{\f0\fcharset0\fprq2 Arial;}}
{\*\listtable{\list\listtemplateid1
{\listlevel\levelnfc23\levelfollow0{\leveltext\'01x;}
{\levelnumbers;}}\listid1}}
{\*\listoverridetable{\listoverride\listid1\listoverridecount0\ls1}}
\f0\fs18
{Starting sentence\par}{\pard\ls1\fi-360\li360
{First point.\par}
{Second point.\par}
{Last point.\par}
}
}
Comment 1 s-joyemusequna 2012-03-19 09:23:21 UTC
Confirmed with LibO 3.5.1 on Windows XP. The size of the "x" is 12 points, should be probably 9 points (like with Word 2007).

Nevertheless a big enhancement : OOo 3.1, LibO 3.3.4, and LibO 3.4.5 don't display the "x" and the tabulators at all.
Comment 2 Jean-Baptiste Faure 2012-03-22 22:43:55 UTC
Miklos: please have a look.

Best regards. JBF
Comment 3 Miklos Vajna 2012-03-23 03:15:01 UTC
Reproduced. However this till take some time to fix - the RTF default is to take the character properties of the current paragraph in the leveltext ("x" in your example), however in Writer we always need a named character style in the list style at the moment.

That proably explains the test document in doc or docx format isn't imported correctly, either.
Comment 4 Roman Eisele 2012-05-31 06:09:31 UTC
This bug is not specific to MacOS X (see comment #1), therefore changed the Platform field to "All/All".
Comment 5 Robinson Tryon (qubit) 2015-12-10 01:08:20 UTC Comment hidden (obsolete)
Comment 6 Miklos Vajna 2015-12-22 22:07:08 UTC
Reset Assignee to default till I actually start looking into this.
Comment 7 QA Administrators 2017-01-03 19:57:34 UTC Comment hidden (obsolete)
Comment 8 soren.hein 2017-01-03 20:57:55 UTC
Still the same bug in 5.1.6.2 on Windows 10
Comment 9 QA Administrators 2018-10-06 02:49:45 UTC Comment hidden (obsolete)
Comment 10 soren.hein 2018-10-09 19:12:39 UTC
Still the same bug in 6.1.2.1 (x64) on Windows 10
Comment 11 QA Administrators 2019-10-10 02:40:28 UTC Comment hidden (obsolete)
Comment 12 soren.hein 2019-11-11 06:45:19 UTC
Still the same bug in 6.3.2.2 (x64) on Windows 10
Comment 13 QA Administrators 2021-11-11 04:14:54 UTC
Dear soren.hein,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://web.libera.chat/?settings=#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug