Bug 46999 - FORMATTING: Paste special into comment: variant "Unformatted text" pastes text with paragraph formatting
Summary: FORMATTING: Paste special into comment: variant "Unformatted text" pastes tex...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Writer-Comments Paste-Special-Unformatted
  Show dependency treegraph
 
Reported: 2012-03-06 04:09 UTC by sdc.blanco
Modified: 2019-01-28 13:01 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
illustration of 'problematic' behaviour (26.68 KB, application/vnd.oasis.opendocument.text)
2012-05-31 09:57 UTC, sdc.blanco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2012-03-06 04:09:49 UTC Comment hidden (obsolete)
Comment 1 sdc.blanco 2012-03-16 06:06:48 UTC Comment hidden (obsolete)
Comment 2 sasha.libreoffice 2012-05-30 04:49:05 UTC Comment hidden (obsolete)
Comment 3 sdc.blanco 2012-05-31 09:57:16 UTC
Created attachment 62342 [details]
illustration of 'problematic' behaviour
Comment 4 sasha.libreoffice 2012-06-01 00:15:00 UTC
Thanks for document with additional explanations
For throwing formatting away exist function Edit->Paste special (shortcut Ctrl-Shift-V), but in comment it not works correctly. If we select "Unformatted text", pasted  text is still formatted.

Steps to reproduce:
0. Open attachment in Writer
1. Select some text in bottom half of page
2. Insert->Comment
3. Ctrl-Shift-V, variant "Unformatted text"
Expected: in comment pasted ordinary text
Actually: in comment pasted one character wide text

Reproduced in 3.3.4 and 3.5.4 on Fedora 64 bit (Windows not tested)
Changing version to 3.3.4 as most early reproduced

In case of "Unformatted text" formatting for comment is taken from that place in text, where comment is placed. In this case it works bad, though formally correct.
Comment 5 Jean-Baptiste Faure 2014-10-04 19:27:55 UTC
Not an enhancement, that is a bug because paste special does not work as it should.

Tested with version 4.3.3.0.0+ (Build ID: 18b9cb260a5ec358f6a7b73362bbc306af0417b1) built at home under Ubuntu 14.04 x86-64.
Reproducible with the master too. Version: 4.4.0.0.alpha0+ Build ID: 24fb87501ef9d5aa715d572de7eb5efe49a0d9c3

Summary made more clear (I hope).

Best regards. JBF
Comment 6 Jean-Baptiste Faure 2014-10-04 19:29:08 UTC
Workaround: menu Format > Clear Direct Formatting works in comments.

Best regards. JBF
Comment 7 QA Administrators 2015-10-14 19:57:58 UTC Comment hidden (obsolete)
Comment 8 sdc.blanco 2015-10-15 13:26:44 UTC
The bug is still present, and has the same appearance as described in Comment 4, if one follows the procedure described there. 

Test with:  LO: 5.0.2.2
Windows 7 (Enterprise)
Comment 9 QA Administrators 2016-11-08 11:33:03 UTC Comment hidden (obsolete)
Comment 10 Jean-Baptiste Faure 2016-11-11 07:44:26 UTC
Nothing changed since last check (comment #6 and comment #7).
Tested in master :
Version: 5.3.0.0.alpha1+
Build ID: c64b8ffe851d3320a15071fa4bc4b0f12e9939d5
Threads CPU : 4; Version de l'OS :Linux 4.8; UI Render : par défaut; VCL: gtk3; Layout Engine: new; 
Ubuntu_16.10_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: group

Best regards. JBF
Comment 11 Xisco Faulí 2017-10-06 13:38:30 UTC
*** Bug 112935 has been marked as a duplicate of this bug. ***
Comment 12 OfficeUser 2017-10-06 13:51:54 UTC
The equivalent report for Calc is bug 112935.
Comment 13 Timur 2018-07-06 12:51:49 UTC
Repro in 6.2+.
Comment 14 Timur 2019-01-28 13:01:50 UTC
Seems like this was fixed already in 6.2. WFM. 
Please test.
If someone still reproduces, please explain.