Bug Hunting Session
Bug 47163 - Profile folder cannot be created in nonANSI path
Summary: Profile folder cannot be created in nonANSI path
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 58495 (view as bug list)
Depends on:
Blocks: User-Profile
  Show dependency treegraph
 
Reported: 2012-03-09 10:26 UTC by Urmas
Modified: 2019-04-14 00:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Error Message of the Bug (100.13 KB, image/png)
2017-05-29 15:03 UTC, Martine
Details
Error Message of the old version (3.3) (87.82 KB, image/png)
2017-06-01 01:23 UTC, Martine
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2012-03-09 10:26:40 UTC
If user name contains characters outside of system ANSI codepage, the LO profile folder cannot be created, causing any application to fail.
Comment 1 Andras Timar 2012-03-11 01:59:38 UTC
Can you give us an example? Can you cd into that directory from a cmd shell?
Comment 2 Urmas 2012-03-11 07:45:29 UTC
Yes; try Cyrillic username on system with English as system default.
Comment 3 Urmas 2012-12-19 10:15:28 UTC
*** Bug 58495 has been marked as a duplicate of this bug. ***
Comment 4 Socratis 2012-12-19 16:41:07 UTC
Reporter from Bug 58495 here. Thanks Urmas for finding out that my report was a duplicate. It didn't occur to me to search for ANSI, only for ASCII and/or locale.

Anyway, during my search, a quick and dirty workaround is to change the system locale to match the language of the user's profile, i.e. Cyrillic in your case or Greek in mine. Of course this is not optimal or wanted in most of the cases.
Comment 5 QA Administrators 2015-01-05 17:52:13 UTC Comment hidden (obsolete, spam)
Comment 6 Artem Ryabov 2015-01-11 21:05:08 UTC
Reproduces on LibreOffice 4.3.5 Windows 7 Ultimate as described in Bug 58495 (2) (Cyrillic user name).
Comment 7 QA Administrators 2016-01-17 20:04:35 UTC Comment hidden (obsolete, spam)
Comment 8 QA Administrators 2017-03-06 14:27:18 UTC Comment hidden (obsolete, spam)
Comment 9 Martine 2017-05-29 15:03:27 UTC
Created attachment 133698 [details]
Error Message of the Bug
Comment 10 Martine 2017-05-29 15:06:38 UTC
I don't know the habit here so I leave New to avoid to put a wrong status.
Comment 11 Martine 2017-05-29 15:20:32 UTC
I have met the bug when I've changed my Windows 10 from hebrew to french (my C:\Users\ name is in hebrew and I didn't succeed to change it). I had as Libre Office 5.0.5 and suddendly I could not access to it (see the attachment for the error message). It says :

<<
LibreOffice 5.0 - Fatal Error
Impossible de lancer l'application ("Impossible to launch the application").
[context="user"] caught unexpected
com.sun.star.ucb.ContentCreationException: Cannot create folder
(invalid path):
>>

I've uninstalled, installed again, the "old" version (5.0.5), the new one (5.3.3), nothing helped.

Help ?
Comment 12 Martine 2017-05-30 17:19:17 UTC
I didn't succeed to test with LibreOffice 3.3 but I tried with Open Office and it seems to be the same problem (the message is some different but happens in the same way) so I putted the version "Inherited from OOo".
Comment 13 Martine 2017-06-01 01:23:58 UTC
Created attachment 133766 [details]
Error Message of the old version (3.3)


The bug is inherited from OO. Here the error message of the 3.3.0 version of Libre Office.
Comment 14 Martine 2017-06-02 18:57:21 UTC
With Abiword there is also a problem, but then you can download the install file in the public user folder (C:\Users\Public\) that Windows creates in addition to your account, and when you do the installation, a shortcut is placed into the general AppData folder (C:\Users\AppData\Roaming\Microsoft\Windows\Start Menu\Programs), and this seems to make it available for all the users, without the problem of the non-ansi characters in the C:\Users\ non-latin-username.

It is not working for Libre Office (I've tried), but it can maybe become a solution. But I'm not good enought in programmation to think about it by myself.
Comment 15 QA Administrators 2018-06-03 02:41:09 UTC Comment hidden (obsolete)
Comment 16 Thomas Lendo 2018-10-14 21:09:52 UTC
Still reproducible. LibreOffice 6.2.0.0.alpha0
Comment 17 Mike Kaganski 2019-04-08 11:38:58 UTC
(In reply to Thomas Lendo from comment #16)
> Still reproducible. LibreOffice 6.2.0.0.alpha0

Very interesting.
I am sure that I have fixed this long before 6.2; and also I just have tested on Russian Windows with a user name "テストabcабв", so that no one usual Windows codepage could hold all characters. And LibreOffice has created its C:\Users\テストабв\AppData\Roaming\LibreOffice\4\user just fine.

Please check and write specific steps required to reproduce.
Comment 18 Martine 2019-04-08 22:16:34 UTC
Hello,
For me I have created a new account with just latin letters, so the problem is not mine any more.
Two remarks however :
You have tested with a user name "テストabcабв" ;
You have got in response :
C:\Users\テストабв\(etc.)
Something is not missing ?
Comment 19 Martine 2019-04-08 22:24:34 UTC
The second remark is more an assumption about the alphabet. Maybe it is fixed for some, but not for others ?
Comment 20 Mike Kaganski 2019-04-09 06:15:02 UTC
(In reply to Martine from comment #18)
> You have tested with a user name "テストabcабв" ;
> You have got in response :
> C:\Users\テストабв\(etc.)
> Something is not missing ?

This is how Windows created a profile directory for the user, not related to LibreOffice operation. Possibly I could have renamed the test user name at some point, which naturally did not reflect on the already created profile directory; I don't remember. The resulting directory (containing all the usual Windows user profile stuff like NTUSER.dat, Documents and all) still has a name consisting of character not representable in usual Windows codepages (and specifically, in the given Windows instance using Windows-1251), which is the point.
Comment 22 Martine 2019-04-09 09:14:37 UTC
Ok, that's right and anyway for me it's fine.
But if you want to reproduce the original problem to be sure, for the test, you should now switch this Russian Windows to English, and then try to access to your LibreOffice with the "テストabcабв" or the "テストабв" username. That's when the bug was happening.
Comment 23 Urmas 2019-04-14 00:07:36 UTC
The profile folder is created (and reused) without errors in 6.3.0alpha.