Bug Hunting Session
Bug 47188 - Feature request: simplify parallel installation
Summary: Feature request: simplify parallel installation
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 55492 (view as bug list)
Depends on:
Blocks: Installer
  Show dependency treegraph
 
Reported: 2012-03-10 08:33 UTC by Frieder
Modified: 2018-09-28 19:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frieder 2012-03-10 08:33:44 UTC
In order to simplify testing and working with different versions,
there should be a option for parallel-installation in the installation-menu.
It would be great, to have a check-box or option-button,
to select parallel-installation right in the installation-menu.
And to round this function up there should be a option,
to import the user-settings from a older version if you chose parallel-installation.

Regards Frieder
Comment 1 Joel Madero 2012-06-29 15:56:18 UTC
I'm going to bring this up in the dev list and see what we come up with. I've honestly felt the same way multiple times but never took the time to bring it up. Marking as NEW -> LOW
Comment 2 Rainer Bielefeld Retired 2012-06-29 22:38:49 UTC
I am not sure whether we really should do that, because that first check box entails several other ones:
- file association
  -- Use parallel installation for ODF documents
  -- USE parallel installation for MS documents
  -- USE pi for other documents?
- user profile
  -- use existing main user profile (risky)
  -- use existing dev user profile
  -- create own new user profile?
- What's with extensions and settings user has been used to have?
- should it be allowed to do several parallel installations?
- should it be possible to run both (all) versions in parallel?

All these decisions have consequences overcharging most "normal" users.

An option "replace existing installation" Y/N might be more nearby to reporter's intention. So he gets the new version, the old one remains on PC for emergency case, and it would be easy (at lease with WINDOWS) to restore the old version. 
But also this solution has many hidden problems what might worry unexperienced users.
Comment 3 bfoman (inactive) 2012-10-04 22:50:24 UTC
*** Bug 55492 has been marked as a duplicate of this bug. ***
Comment 4 kavalec74 2012-10-21 23:58:39 UTC
I like the idea of Rainer: "An option "replace existing installation" Y/N might be more nearby to reporter's intention. So he gets the new version, the old one remains on PC for emergency case, and it would be easy (at lease with WINDOWS) to restore the old version."
Comment 5 Cor Nouws 2012-10-22 07:03:18 UTC
Hi,
Had a short discussion on this topic with some people at LibrOfficeConference and the general opinion is that it is a good idea - details to be discussed - but only on developer builds. Not on final versions.
In order to prevent confusion with normal users.
Hmm. but then remains the question: what with betas and waht with release candidates? We skipped that detail...
IMO those should have the option too.
Comment 6 kavalec74 2012-10-22 12:00:59 UTC
Hi Cor, I am confused with the builds - there are 2 or 3 instable releases. There should be only one stable and good tested build. I would prefer a new version less often, but really stable - without crashes while pasting or editing formulas. Calc supports more then o milion of rows, in theory. My file has lass than 200kB and LO has problems with it. Adding a new row is very slow. I am an advanced user of Calc, I use formulas, filters, conditional comments, grouping, styles and various sheets, with 200 rows aprox, all - 10.000 cells
Comment 7 Timur 2018-07-17 14:09:25 UTC
There are already techniques for parallel use that depend on OS:
- simple http://tdf.io/siguiexe in Windows that merely extracts installer
- very simple Appimage in Linux that runs single-file instance
- Bash Script from http://pastebin.com/L6SFSYFR to Extract Parallel LO (no installation) from downloaded and unzipped LO folder with DEBS. 

All those are for advanced users and testers.
I think this bug is quite unnecessary and suggest be WontFix.