Bug Hunting Session
Bug 47240 - Chemdraw OLE objects not detected
Summary: Chemdraw OLE objects not detected
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: OLE-Objects
  Show dependency treegraph
 
Reported: 2012-03-12 09:34 UTC by Sean Greenhow
Modified: 2018-09-24 18:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
File containing 3 OLE objects contained in a table (112.00 KB, application/msword)
2012-03-12 09:34 UTC, Sean Greenhow
Details
Comparison document where the OLE object is detected (13.00 KB, application/msword)
2012-03-12 09:36 UTC, Sean Greenhow
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sean Greenhow 2012-03-12 09:34:06 UTC
Created attachment 58329 [details]
File containing 3 OLE objects contained in a table

The attached file contains Chemdraw OLE objects.When opened via Office you can then activate each of them (assuming you have Chemdraw installed). When loaded in LibreOffice they cannot be activated. Note Chemdraw requires a Windows environment, and I used XP.

If you use the LibreOffice SDK no embedded objects are detected, but it does detect shape objects. I ran the SDK code under Linux Fedora 14.
Comment 1 Sean Greenhow 2012-03-12 09:36:41 UTC
Created attachment 58330 [details]
Comparison document where the OLE object is detected

Enclosed is another document that LibreOffice can detect the OLE object.
Comment 2 sasha.libreoffice 2012-06-01 03:00:01 UTC
Thanks for bugreport
reproduced in 3.3.4 and 3.5.4 on Fedora 64 bit and in 3.5.2 on Windows 7
If we press F5, there are no OLE objects

What is interesting: if first attachment save as docx using msWord 2007, then Writer opens it with OLE objects in Navigator, but they have empty names.
May be source of problem is in strange names of objects?
Comment 3 sasha.libreoffice 2012-06-01 03:08:11 UTC
Second attachment, converted to docx, also opens in Writer in navigator with empty name of OLE. Therefore problem not in OLE names.
Comment 4 QA Administrators 2015-01-05 17:52:00 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2015-01-27 17:46:46 UTC
Confirmed.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-25_23:07:36
Comment 6 QA Administrators 2016-02-21 08:36:49 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-03-06 15:38:24 UTC Comment hidden (obsolete)
Comment 8 Bartosz 2017-05-18 20:21:29 UTC
This issue was already resolved in LibreOffice 5.4

*** This bug has been marked as a duplicate of bug 31814 ***
Comment 9 Timur 2017-08-24 18:33:27 UTC
This bug was about Chemdraw OLE not Chemdraw preview, that was solved.
Looks like this should be kept as New.
Comment 10 QA Administrators 2018-08-25 02:42:39 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug