Bug 47303 - FORMATTING: Behaviour of Options "Basic Fonts (Western)" is not transparent
Summary: FORMATTING: Behaviour of Options "Basic Fonts (Western)" is not transparent
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-14 04:18 UTC by Harald Koester
Modified: 2012-08-30 01:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2012-03-14 04:18:12 UTC
Problem description: 

In order to illustrate the problem some steps (Only the basic font "Default" is considered here, other basic fonts behave equal):
[1] Start LibreOffice and open a new text document (Doc1). 
[2] Tools > Options... > LibreOffice Writer > Basic Fonts (Western) > Click "Default" in order to start with the same initial situation.
[3] Choose another Default basic font (Font1), then "OK".
[4] Open another new text document (Doc2), then open Options dialog again. Font1 is displayed as Default basic font.
[5] Choose another Default basic font (Font2), then "OK".
[6] Change back to Doc1 and display options again. Font1 is displayed as Default basic font. I expected Font2, hence in step [5] the font has been changed to Font2.  Go on either with [7a] or [7b]
[7a] Click "Cancel".
[8a] Open a third new text document (Doc3). Guess which font is now the basic font! It's Font2, though one step before Font1 is displayed as current basic font. 
[End]
[7b] Click "OK".
[8b] Open a third new text document (Doc3). Now Font1 is displayed as basic font. Then "OK".
[9b] Change to Doc2. The basic font is Font2 although Font1 is displayed as current font in step [8b].

First I was rather confused and it took me a long time to understand this behaviour. I am still not sure if I understand everything correctly: 
(a) Always if you change to or open an existing document the fonts of the basic paragraph styles (Default, Heading,...) of this document are displayed. 
(b) If you change the font of a basic paragraph style with the Paragraph Style dialog, the changed font is afterwords also displayed in the option dialog.
(c) Always if you create a new document, those fonts are used, which have been acknowledged lastly with "OK". This may be a long time ago. 
(d) The only way to display the options is to create a new document. 
(e) If you change the options (with "OK") the basic paragraph styles of the current document are also changed.

Proposal in order to prevent the confusion:
(a) Change heading of this option category to "Basic fonts (Western) of new documents". 
(b) The basic fonts of the current document should no longer displayed in the options dialog. 
(c) The check box "Current document only" can be dropped. 
(d) Introduction of new tab "Basic fonts (Western)" in Properties dialog (Menu: File > Properties...). In this new tab the basic fonts of the current document are displayed and can be changed. 
(e) In the options dialog a hint "Viewing and changing basic fonts of current document go to: Menu: File > Properties... > Tab 'Basic Fonts (Western)' " or similar could be useful.

I did not check the behaviour with option categories "Basic Fonts (Asian)" and "Basic Fonts (CTl)". I expect an equal behaviour as described above.

Problem exists also in Version 3.4.5.

Hint: In bug 43786 I described a similar problem with an option, which is used as a property of a document.
              
Browser: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.27) Gecko/20120216 Firefox/3.6.27
Comment 1 Harald Koester 2012-03-14 09:54:16 UTC
Additional Problem:

If you create a new HTML document the Default basic font is used for nearly all predefined paragraph styles. The other basic fonts are not used in HTML documents. If you change this basic font 'Default' while displaying a HTML document the fonts of this document are not changed. This is different to text documents where the font is changed, when you save the options. 

Expected behaviour: Hence there is a separate category for HTML documents ("LibreOffice Writer/Web") I expect, that the options under "Basic Fonts (Western)" have no influence on HTML documents.
Comment 2 Joel Madero 2012-08-30 01:30:32 UTC
I have confirmed what you are saying but honestly, I don't think it's a bug. Changing the default font to DIFFERENT fonts with two different (or more) open writer documents isn't how Libre Office is intended to be used. The default font is set for the document and once you close it, from that point on future documents will have the default font selected. Furthermore, if you create a new document from within another document, it will "carry" the same settings as the one that you are creating from (ie. if you have doc1 open and you create doc2, doc2 will have the same settings as doc1 but if you change something in doc2 settings and create another document from within doc2, doc3 will have same settings as doc2). But if you change defaults for Doc1 and then close it, every document that you create, regardless of from where, will have the new defaults unless you change them again. Defaults aren't made to be changed to different things with two opened documents. 

I'm marking as NOTABUG as it works as intended.

As for the later issue, sounds different, please open a new bug. 

Thanks for reporting.