Bug Hunting Session
Bug 47314 - Cannot use shortcut key ALT-Q in Hebrew keyboard layout - CONFIGURATION L10N
Summary: Cannot use shortcut key ALT-Q in Hebrew keyboard layout - CONFIGURATION L10N
Status: RESOLVED DUPLICATE of bug 41169
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-14 10:53 UTC by Gil Shwartz
Modified: 2015-03-12 20:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gil Shwartz 2012-03-14 10:53:27 UTC
I'm using two keyboard layouts - US and HE. In HE layout, the Q key produces /. I defined a keyboard shortcut ALT-Q to change paragraph style. When typing in Hebrew (HE keyboard layout), pressing ALT-Q fails to change the paragraph style. Defining the same paragraph style change to keyboard shortcuts ALT-E and ALT-W works fine. For the sake of completeness, in HE layout, the W key produces ', while the E key produces a Hebrew letter. Also, it did not matter if the shortcut was defined for LibreOffice or Writer.
Comment 1 sasha.libreoffice 2012-06-05 04:30:07 UTC
Thanks for bugreport
reproduced in 3.3.4 and 3.5.4 on Fedora 64 bit (Windows not tested)
in my case layout name is "il", used command "Decrease indent" for testing

Changing version to 3.3.4 as most early reproducible
Comment 2 matanya 2013-07-04 20:15:17 UTC
Still around in 4.0.42. anything new?

using gnome on arch linux. not reproduced in other desktop env such as xfce or MATE. is there anything different done in interaction with gnome?
Comment 3 Gil Shwartz 2014-12-29 15:07:26 UTC
Still being reproduced in Mint 13, Mate 1.6, LO 4.3.5.2. Unlike the original report, ALT-W (which produces ') is not also not working as a keyboard shortcut.
Comment 4 Lior Kaplan 2015-03-12 20:48:27 UTC

*** This bug has been marked as a duplicate of bug 41169 ***