Download it now!
Bug 47330 - Runtime Exception caused by unrelated environment settings
Summary: Runtime Exception caused by unrelated environment settings
Status: RESOLVED DUPLICATE of bug 42961
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-14 18:31 UTC by Andrew
Modified: 2012-03-14 19:53 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew 2012-03-14 18:31:06 UTC
openSUSE 12.1 (x86_64)

When the environment variable "DATA" is set to a value with a leading "/", libreoffice and any of it's components fail to start.

In the example following, I have a pretty much empty environment, and demonstrate that "unopkg" terminates when "DATA" is set:


co524imac19:/root/office # env
PROFILEREAD=true
PATH=/bin:/usr/bin
_=/usr/bin/env
co524imac19:/root/office # unopkg list                       
All deployed user extensions:

<none>
co524imac19:/root/office # export DATA=/
co524imac19:/root/office # unopkg list  

ERROR: [context="user"] caught unexpected exception!

unopkg failed.
terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'
/usr/bin/unopkg: line 2:  6484 Aborted                 /usr/lib64/libreoffice/program/unopkg "$@"
Comment 1 Urmas 2012-03-14 19:53:05 UTC

*** This bug has been marked as a duplicate of bug 42961 ***