Bug Hunting Session
Bug 47396 - FILEOPEN: Сrash when opening large rtf-files
Summary: FILEOPEN: Сrash when opening large rtf-files
Status: CLOSED DUPLICATE of bug 44736
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: BSA
Keywords: filter:rtf, regression
Depends on:
Blocks:
 
Reported: 2012-03-16 01:10 UTC by itdep.ggps
Modified: 2015-12-15 11:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Construction documents prepared in the software package AVK-5 (322.37 KB, application/octet-stream)
2012-03-16 01:31 UTC, itdep.ggps
Details

Note You need to log in before you can comment on or make changes to this bug.
Description itdep.ggps 2012-03-16 01:10:11 UTC
Problem description: problem with working with the large rtf-files

Steps to reproduce:
1. Simply open the file

Current behavior: Hangs or crashes without an error message

Expected behavior: Normal opening a file

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.79 Safari/535.11
Comment 1 itdep.ggps 2012-03-16 01:31:36 UTC
Created attachment 58542 [details]
Construction documents prepared in the software package AVK-5
Comment 2 s-joyemusequna 2012-03-16 12:23:10 UTC
Confirmed. Tested on Windows XP.

Hangs with LibO 3.4.5: no error message. Massive CPU and memory usage.
Out of memory with LibO 3.5.1.

Works with LibO 3.3.4.

Could be a duplicate of Bug 44736.
Comment 3 Jean-Baptiste Faure 2012-03-23 14:57:50 UTC
No crash nor freeze for me with LO 3.5.3 rc0+ (LibreOffice 3.5.3rc0+ 
Version ID : a6604b0-a73d29c-6845e52-f269e46-b01560f).

No crash nor freeze for me with LO 3.5.2
Both tested under Ubuntu 11.10 x86_64

Miklos: please, could you have a look ?

Best regards. JBF
Comment 4 Miklos Vajna 2012-03-30 06:34:19 UTC
No crash or hang here, either, probably due to the memory leak fix which landed in 3.5.2rc1. The speed of the import is slow, though.

*** This bug has been marked as a duplicate of bug 44736 ***
Comment 5 Jean-Baptiste Faure 2012-04-30 09:49:02 UTC
closing.
Comment 6 Robinson Tryon (qubit) 2015-12-15 11:48:42 UTC
Migrating Whiteboard tags to Keywords: (rtf_filter -> filter:rtf)
[NinjaEdit]