Download it now!
Bug 47441 - [SVG] radial gradients are not handled properly
Summary: [SVG] radial gradients are not handled properly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 81014 (view as bug list)
Depends on:
Blocks: SVG-Open
  Show dependency treegraph
 
Reported: 2012-03-17 06:53 UTC by Valek Filippov
Modified: 2018-06-20 17:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Testing file (2.00 KB, image/svg+xml)
2012-03-17 06:53 UTC, Valek Filippov
Details
"Open" on top and "Insert" at the bottom. (14.70 KB, image/png)
2012-03-17 06:54 UTC, Valek Filippov
Details
Radial gradient as rendered by Firefox 49.0.2 (18.05 KB, image/png)
2016-11-14 11:35 UTC, Jouni Järvinen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Valek Filippov 2012-03-17 06:53:51 UTC
Created attachment 58603 [details]
Testing file

How to reproduce
----------------
1. Open attached SVG file.
2. Insert attached SVG file into the same document
("Insert->Picture->From file...").

Expected results
----------------
Both pictures look the same.

Results with lodraw 3.5.1 release
---------------------------------
Radial gradient outside colour stop seems to be twice (?) farther than it should be.

(Text is missed, but I'm going to open another bug(s) for text issues with SVG
"Open").
Comment 1 Valek Filippov 2012-03-17 06:54:37 UTC
Created attachment 58604 [details]
"Open" on top and "Insert" at the bottom.
Comment 2 sasha.libreoffice 2012-06-12 01:56:07 UTC
Thanks for bugreport
tested on Fedora 64 bit:
in 3.3.4: Insert->Picture->From file and File->Open shows bug

in 3.5.4: Insert->Picture->From file works correctly
File->Open shows bug
(Windows not tested)
Comment 3 Thomas Arnhold 2013-10-14 23:29:10 UTC
NOT reproducible anymore:

Version: 4.1.2.3
Build ID: 40b2d7fde7e8d2d7bc5a449dc65df4d08a7dd38
Comment 4 sasha.libreoffice 2013-10-15 07:59:23 UTC
Still opens as square instead of circle
Reproduced in 4.1.2.3 on Fedora (RFR) 64 bit using File->Open
Comment 5 A (Andy) 2015-04-05 21:12:04 UTC
Reproducible with LO 4.4.1.2 (Win 8.1): rectangle instead of circle, missing text
Comment 6 A (Andy) 2015-04-05 21:32:47 UTC
*** Bug 81014 has been marked as a duplicate of this bug. ***
Comment 7 Robinson Tryon (qubit) 2015-12-09 18:52:41 UTC Comment hidden (obsolete)
Comment 8 Jouni Järvinen 2016-11-14 11:34:40 UTC
LO 5.2.2.2 (x64), Window$ 7 Ultimate SP1 x64, there are 2 problems with that test file:
1) The gradient shows up as a square, but otherwise same gradient as rendered by Firefox for instance. See the attachment added below.
2) No matter which shape under 'Area' bar on the right I take while the gradient square is selected, the gradient makes absolutely no change. Although the selection does stick, like changing from the default 'Ellipsoid' to 'Radial' stays without visible effect. I could be doing something wrong here, however.
Comment 9 Jouni Järvinen 2016-11-14 11:35:58 UTC
Created attachment 128743 [details]
Radial gradient as rendered by Firefox 49.0.2
Comment 10 QA Administrators 2017-11-15 09:15:40 UTC Comment hidden (obsolete)
Comment 11 Roman Kuznetsov 2018-06-16 15:21:35 UTC
still repro in 6.1.beta 1

need check it in to 6.1 beta 2
Comment 12 Roman Kuznetsov 2018-06-17 10:54:03 UTC
(In reply to kompilainenn from comment #11)
> still repro in 6.1.beta 1
> 
> need check it in to 6.1 beta 2

In

Version: 6.1.0.0.beta2+ (x64)
Build ID: fe1a23b5c49c94410a604c8d4a6f50f43d575403
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:libreoffice-6-1, Time: 2018-06-17_06:31:41
Locale: ru-RU (ru_RU); Calc: CL

Menu File->Open: radial gradient opens fine (circle without square) in Draw with text.

This bug is WFM now