Bug 47518 - LO ignores locale settings in windows
Summary: LO ignores locale settings in windows
Status: CLOSED DUPLICATE of bug 46448
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Windows (All)
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 46448
Blocks: Desktop-Integration
  Show dependency treegraph
 
Reported: 2012-03-19 08:54 UTC by Aaron
Modified: 2018-09-03 08:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron 2012-03-19 08:54:21 UTC
LO 3.4.5/3.5.1 for windows ignores decimal separator settings from OS locale settings.
For example, I use windows locale set to russian.
Default decimal separator for this locale set by Microsoft is a comma, but in reality most times this decimal separator is modified to be a dot.
LibreOffice completely ignores modified locale settings and always sets decimal separator to a comma.
The only workaround is to change language in LO to German(Switzerland) or UK. This depends on date format settings you want to get.
Comment 1 Pedro 2012-03-25 02:25:13 UTC
I can confirm this happens under Windows XP Pro x86. I have the same problem.

It is not that locale is ignored. Locale is enforced. It's the customized settings that are ignored.

Apparently LO doesn't expect customized settings.
Comment 2 Eike Rathke 2012-05-30 13:11:40 UTC
There currently is no system layer for locale data to merge in OS settings that vary from the locale's settings. This needs to be implemented.
Comment 3 Eike Rathke 2018-09-03 08:22:51 UTC

*** This bug has been marked as a duplicate of bug 46448 ***