Bug Hunting Session
Bug 71849 - Allow custom locale settings for thousands separator, currency, time
Summary: Allow custom locale settings for thousands separator, currency, time
Status: CLOSED DUPLICATE of bug 46448
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-20 18:54 UTC by Ady
Modified: 2015-02-19 17:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ady 2013-11-20 18:54:26 UTC
In my OS I have locale settings based on English (USA), but then I have customized settings according to my needs.

In LO Options -> Languages -> Locale setting, I can set “English (USA)”, but I can't set my exact custom settings.

I tried to partly compensate by using “Date acceptance patterns”, but it is not effectively helping in my case. Additionally, this field would only add date input format(s) to the default (English USA in my case), which is not enough in my case and not what I need.

I couldn't find whether there is any additional method to customize the locale settings in LibreOffice. I'm talking about customizing formats to numbers (“as OS” decimal separator is already there, but thousand separator is not), custom currency, custom time...

I'd like to request locale options for customization, instead of using a default preset language/country.

One possible example of such enhancement could be to enable the “Languages -> Locale setting” field to be set “as the OS” in addition to the current list of language/country.

Having individual customization fields (just as in the OS itself) is a second alternative, more powerful enhancement.

TIA,
Ady.
Comment 1 Joel Madero 2013-12-22 18:59:07 UTC
What is your OS? Marking as NEEDINFO - what OS is it and then mark as UNCONFIRMED

Thanks
Comment 2 Ady 2013-12-23 17:57:36 UTC
@Joel, thank you for your reply.

Since this is an enhancement request (for all OS), I have not added my specific OS in the corresponding field.

The reason I started my request with "In my OS I have locale settings ..." is to make it clear when I am referring to the locale settings in LO, and when I am referring to locale settings in the OS.

FWIW, the situation I presented here refers to Windows Vista in my particular case, but the same text could be applied to any OS with customized locale settings in it.
Comment 3 Owen Genat (retired) 2014-07-18 08:10:11 UTC
This would appear to at least partly overlap with bug 47518. I am adding that bug to the See Also list.
Comment 4 Owen Genat (retired) 2014-08-24 14:30:47 UTC
Bug 46448 (date format and decimal separator) added to Depends on field as this request definitely overlaps with that report. Summary amended for clarity i.e., to indicate only non-overlapping aspects (although this could be amended if this is to become the primary enhancement for allowing fully customised locale settings). I feel this would require developer input / comment. Component set to Localisation. Status set to NEW.
Comment 5 Eike Rathke 2015-02-19 17:07:48 UTC

*** This bug has been marked as a duplicate of bug 46448 ***