Download it now!
Bug 47590 - DRAW: hatched polygons saved in 3.4 are corrupted in 3.5 (FILEOPEN)
Summary: DRAW: hatched polygons saved in 3.4 are corrupted in 3.5 (FILEOPEN)
Status: RESOLVED DUPLICATE of bug 47406
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: x86 (IA32) Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-20 08:30 UTC by Peter Schmitt
Modified: 2012-03-29 16:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
odg with hatched polygon (like map of a building) (35.89 KB, application/vnd.oasis.opendocument.graphics)
2012-03-20 08:30 UTC, Peter Schmitt
Details
situation when FILESAVE in 3.4.5 (113.76 KB, image/jpeg)
2012-03-20 08:31 UTC, Peter Schmitt
Details
situation after FILEOPEN in 3.5.1.2 (119.16 KB, image/jpeg)
2012-03-20 08:32 UTC, Peter Schmitt
Details
situation after FILEOPEN in nightly build LOdev3.5.2 20120319 (115.69 KB, image/jpeg)
2012-03-20 08:33 UTC, Peter Schmitt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Schmitt 2012-03-20 08:30:08 UTC
Created attachment 58760 [details]
odg with hatched polygon (like map of a building)

In the case a DRAW document with small scales contains polygonal hatched areas (german: Polygone mit Schraffur), and this document was saved with LibO 3.4 the objects will be corrupted when opened in LibO 3.5

The given example will IMHO reproduce the effects.
Test conditions of the following benchmark data:
OS:  Windows Xp Pro SP3
CPU: Intel Core i5-2410M 2.30 GHz
RAM: 3 GB

Effects reproduced with LibO 3.5.0 Release, 3.5.1 Release, LOdev3.5.2RC-nightlyBuild20120319 on WindowsXpSP3 
AND LibO 3.5.0 Release on Windows7Pro-64bit


Attachments:
example_plan_hatched_polygons_LO3.4.5.odg: Source saved in LibO 3.4.5

Screenshots:
01-FILESAVE-in_LibO3.4.5-example_plan_hatched_polygons_LO3.4.5.jpg
02-FILEOPEN-in-LibO3.5.1.2-example_plan_hatched_polygons_LO3.4.5.jpg
03-FILEOPEN-in-LOdev3.5.2NB20120319-example_plan_hatched_polygons_LO3.4.5.jpg
Comment 1 Peter Schmitt 2012-03-20 08:31:26 UTC
Created attachment 58761 [details]
situation when FILESAVE in 3.4.5
Comment 2 Peter Schmitt 2012-03-20 08:32:22 UTC
Created attachment 58762 [details]
situation after FILEOPEN in 3.5.1.2
Comment 3 Peter Schmitt 2012-03-20 08:33:38 UTC
Created attachment 58763 [details]
situation after FILEOPEN in nightly build LOdev3.5.2 20120319
Comment 4 Kai Dietrich 2012-03-21 02:19:14 UTC
Confirmed with LibreOffice 3.5.0 and the attached Testfile.

I think, the same Bug, I have with other Libre Draw Files. Generate with 3.4.3 the File is fine and after FILESAVE and FILEOPEN in 3.5.0 the positions of many objects are changed.
I can restore this Bug, If I export a Drawing from Inkscape in ODG and open it with LibreOffice 3.5.0: After FILEOPEN the drawing is fine, after FILESAVE and FILEOPEN it is distroyed.
Comment 5 Laurent BP 2012-03-28 04:56:05 UTC
Hi,

There are other problems of compatibility between LibO 3.4 and LibO 3.5
Cf fdo#47699 FILEOPEN: object saved with 3.4 opens bad with 3.5 
https://bugs.freedesktop.org/show_bug.cgi?id=47699
Comment 6 Laurent BP 2012-03-28 12:39:37 UTC
Issue #47406
https://bugs.freedesktop.org/show_bug.cgi?id=47406
Almost all graphics that have internal circuits are not rending correctly
deals with same kind of problem
Comment 7 Regina Henschel 2012-03-29 16:16:32 UTC
I have tried the document with LO3.5.2rc2 and can see the error no longer. So I think too, that it is the same reason as Issue #47406.

*** This bug has been marked as a duplicate of bug 47406 ***