Bug Hunting Session
Bug 47615 - VIEWING: Documents looks different between Linux and Windows using the same LibreOffice version
Summary: VIEWING: Documents looks different between Linux and Windows using the same L...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 81965 101268 (view as bug list)
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2012-03-20 14:37 UTC by moray33
Modified: 2018-10-27 19:14 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
An example of the problem (268.50 KB, application/msword)
2012-03-20 14:37 UTC, moray33
Details

Note You need to log in before you can comment on or make changes to this bug.
Description moray33 2012-03-20 14:37:50 UTC
Created attachment 58785 [details]
An example of the problem

Problem description: I made some documents and tried to open them in Linux (Kubuntu/Xubuntu) and Windows (7) and they look a little bit different, having the used fonts installed in both systems. For example, one thing that was originally at the end of a page in Windows, in Linux appears at the beggining of the next page.

I don't know why this happens, maybe lines or fonts have different heights or something. By the way, I don't know if it's relevant but in these documents I tried I used fontwork.

Current behavior: Documents looks different in Linux and Windows using the same version of LibreOffice (4.5)

Expected behavior: Documents looks the same way in both systems.

Platform (if different from the browser): Kubuntu 12.04/Xubuntu 11.10 and Windows 7
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 1 sasha.libreoffice 2012-06-14 02:05:27 UTC
Thanks for bugreport
I also often encounter problem that on Linux text is slightly bigger than on Windows. Approximately on 7%. Layout becomes corrupted.
Comment 2 ydutrieux 2012-12-17 17:10:08 UTC
I confirm this on Libo 4.0 Version 4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)

Win7- 32bits and Ubuntu 12.04 64bits (same police installed on the two os).
Comment 3 Mabin 2014-08-01 00:12:13 UTC
I think that maybe LibreOffice is using different font library each OS.

https://bugs.freedesktop.org/show_bug.cgi?id=81965
Comment 4 Mabin 2014-08-01 00:13:11 UTC
*** Bug 81965 has been marked as a duplicate of this bug. ***
Comment 5 geeker 2015-08-25 20:35:07 UTC
This bug is reproduced in Version 5.0.0.5.
Comment 6 Buovjaga 2016-08-07 14:56:46 UTC
*** Bug 101268 has been marked as a duplicate of this bug. ***
Comment 7 QA Administrators 2018-07-28 02:43:37 UTC Comment hidden (obsolete)
Comment 8 Thomas Lendo 2018-10-27 19:14:42 UTC
Cannot reproduce.

Version: 6.2.0.0.alpha1+
Build ID: 5d2ab49cbda1d7aea1019478abe0163e1f40a121
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); Calc: threaded
from today

Maybe fixed with the changes that Khaled made in version 5.3 (follow-up bugs see Bug 103729 HarfBuzz-regressions).