Bug 47673 - SLIDESHOW: Particular fonts like "Century Schoolbook L" too narrow with hardware acceleration.
Summary: SLIDESHOW: Particular fonts like "Century Schoolbook L" too narrow with hardw...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 43009 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-21 11:36 UTC by info.kalsan
Modified: 2015-01-29 12:07 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A screenshot of the described problem. (333.90 KB, image/jpeg)
2012-03-21 11:36 UTC, info.kalsan
Details
test case presentation (19.30 KB, application/vnd.oasis.opendocument.presentation)
2012-03-22 09:52 UTC, sasha.libreoffice
Details
Screenshots show Problem with Ubuntu LibO (212.28 KB, application/vnd.oasis.opendocument.graphics)
2012-04-04 09:45 UTC, Rainer Bielefeld Retired
Details
screenshot of presentation in slideshow mode on Fedora 64 bit, hardware accel. enabled (119.57 KB, image/jpeg)
2012-04-04 22:02 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description info.kalsan 2012-03-21 11:36:11 UTC
Created attachment 58831 [details]
A screenshot of the described problem.

Problem description: A text in the font Century Schoolbook L is displayed all right in the editor, but when I start the slideshow, the font becomes very thin: the letters are narrow and there's a lot of space between them.
Please see screenshot.
Comment 1 vitriol 2012-03-21 11:44:25 UTC

*** This bug has been marked as a duplicate of bug 46901 ***
Comment 2 info.kalsan 2012-03-22 09:43:12 UTC
My system is Ubuntu 12.04. Also happened in 11.10.
Comment 3 sasha.libreoffice 2012-03-22 09:52:23 UTC
Created attachment 58883 [details]
test case presentation
Comment 4 sasha.libreoffice 2012-03-22 09:53:42 UTC
Thanks for bugreport
Reproduced in 3.3.4 and 3.5.1 on Fedora 64 bit and Windows XP 32 bit
Changing version to 3.3.4 as most early reproducible
Comment 5 Rainer Bielefeld Retired 2012-04-01 02:11:43 UTC
DUPLICATED again.

@info.kalsan@valaiscom.ch:
Please never reopen Bugs, <https://wiki.documentfoundation.org/BugReport_Details#How_to_reopen_Bugs>!

*** This bug has been marked as a duplicate of bug 46901 ***
Comment 6 sasha.libreoffice 2012-04-02 01:38:23 UTC
Strange. How Linux specific bug is duplicate to Windows specific bug?
But let will hope that it indeed fixed.
Comment 7 Rainer Bielefeld Retired 2012-04-02 02:10:37 UTC
@Sasha:
A user named "sasha" forgot to modify OS after confirmation in Comment 4 - and we all, too ;-)

Reporter's screenshot IMHO shows the Bug 46901 problem, I can't tell whether there is an additional "L" problem for Linux; For WIN the Bug 46901 problem does not match with the Version 3.3.4 you set here. But My Ubuntu LibO 3.4.4 (VirtualBox) shows the SLIDESHOW hardware acceleration problem good visible in text, more or less invisible in Heading of test case presentation. I  WIN LibO 3.4.5 the problem definitively does not exist. May be the problem appeared more early in Linux?  May be you can contribute some additional information?
Comment 8 sasha.libreoffice 2012-04-02 02:51:19 UTC
Sorry for my previous comment. I will retest it in next version of LO
Comment 9 sasha.libreoffice 2012-04-04 07:30:37 UTC
reproduced in 3.5.2.2 on Fedora 64 bit, Hardware acceleration only bug
Comment 10 Rainer Bielefeld Retired 2012-04-04 09:45:49 UTC
Created attachment 59484 [details]
Screenshots show Problem with Ubuntu LibO

I did those creenshots from Ubuhtu with LibO 3.4.4 (VirtualBox), you see normal character View in edit mode and too narrow ones in SLIDEWHOW with hardware acceleration
Comment 11 Rainer Bielefeld Retired 2012-04-04 09:50:01 UTC
Reopened due to my results in "Screenshots show Problem with Ubuntu LibO". Looks very similar to symptoms in Bug 46901, but it started far before 3.5 (so different roots) and it seems still in 3.5.2 due to Comment 9

@sasha:
What did you reproduce? A "narrow L" problem or more or less all text with too narrow letters?

@Michael:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug.
Comment 12 sasha.libreoffice 2012-04-04 22:02:49 UTC
Created attachment 59503 [details]
screenshot of presentation in slideshow mode on Fedora 64 bit, hardware accel. enabled
Comment 13 Rainer Bielefeld Retired 2012-04-04 23:50:26 UTC
@sasha
Yes, that's exactly the problem I see.

@all:
The problem is not limited to "Century Schoolbook L", I additionally see it with "Nimbus Sans L", "URW Palladio L", "Courier 10 pitch", but not with "Nimbus Sans" and "Ubuntu mono Right" (others not tested).
"Standar Symbols L" shows an other problem, there the letters are shown bold in a strange way.
Comment 14 Rainer Bielefeld Retired 2012-10-14 06:39:56 UTC
I listed this one under <http://wiki.documentfoundation.org/WikiAction/edit/HardHacks#In_Review_Process>

@sasha:
What was our latest result? This particular one Linux only? Please correct version picker if I remember that wrongly!
Please always mention Version you used for tests, your " screenshot of presentation in slideshow mode on Fedora 64 bit, hardware accel. enabled" is not very useful if we do not know with what version you did the test. Still reproducible with 3.6.3?

I see the problem with LibO 3.5.4.2 on Ubuntu 12.04 64 bit (Virtualbox), but not with "LibreOffice 3.5.0 Beta0  - WIN7 Home Premium (64bit) German UI [Build:ef91e38-b1d4df6-090bcba-45cf606-05891e7]"
Comment 15 Vossman 2012-10-14 16:47:14 UTC
You know, I used to have this bug in the early 3.4 series, but I do not have it anymore.
Comment 16 Thorsten Behrens (allotropia) 2012-10-26 20:29:12 UTC
*** Bug 43009 has been marked as a duplicate of this bug. ***
Comment 17 sasha.libreoffice 2012-11-08 11:57:40 UTC
reproduced in 3.5.7 (installed from Fedora repo)
and in 3.6.3 (installed from libreoffice.org)
both on RFR 17 "Beefy miracle" 64 bit
Comment 18 QA Administrators 2015-01-05 17:50:57 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.3.5 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
Comment 19 info.kalsan 2015-01-05 20:01:49 UTC
I am unable to reproduce the bug because I changed my operating system and I'm using different fonts now.
Comment 20 Buovjaga 2015-01-29 12:07:18 UTC
No problem anymore -> WFM.

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-01-25_23:58:40

and

Version: 4.3.3.2
Build ID: 430m0(Build:2)