Download it now!
Bug 47699 - FILEOPEN: object saved with 3.4 opens bad with 3.5
Summary: FILEOPEN: object saved with 3.4 opens bad with 3.5
Status: RESOLVED DUPLICATE of bug 47406
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-22 00:41 UTC by Yusuf Bolu
Modified: 2013-06-19 09:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
the pictures of saved and opened object. (178.08 KB, image/png)
2012-03-22 00:41 UTC, Yusuf Bolu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yusuf Bolu 2012-03-22 00:41:02 UTC
Created attachment 58850 [details]
the pictures of saved and opened object.

Problem description: I had an odg drawing created some time ago with OpenOffice Draw in Windows. I opened it with LibreOffice 3.5 and saw that an object was distorted. I opened the file with LibreOffice 3.4 in Windows, there was no problem.

Steps to reproduce:
1. In LibreOffice 3.4 (or below) open a new .odg document.
2. Draw three rectangular strips close to each other.
3. Group the strips.
4. Draw a circle on the strips to cover them partially.
5. Select the grouped strips and the circle together. Take intersection of them, so you'll have three strips with their narrow edges rounded.
6. Select the shape and give it some some rotation from Position and Size.
7. Save it as .odg
8. Open the saved odg document with LibreOffice 3.5.
9. The drawing is not what you created.

Current behavior:A specific object created and saved with 3.4 (or below) in odg format doesn't open the same in 3.5

Expected behavior: An odg file is expected to be stable between software versions.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 1 Laurent BP 2012-03-28 05:34:11 UTC
Hi,

I can reproduce on Win7 with LibO 3.4.6 and LibO 3.5.1.
The same problem occurs with extension "Clipart gallery of danger signs"
http://extensions.libreoffice.org/extension-center/gallery-of-danger-signs

1. Install extension and restart LibO
2. Open Gallery
3. Select "Signalétique Chemical Product" Them
4. Drag and drop first clipart (GHS-general)
=> with LibO 3.4 the clipart is correctly inserted. OK
=> with LibO 3.5 the different elements of the clipart are separated
http://imageshack.us/photo/my-images/820/immaginesmr.png/

However, the bug does not apply to all cliparts. I could not identify what makes wrong exactly.

This is a regression.
Comment 2 Laurent BP 2012-03-28 05:54:15 UTC
(In reply to comment #0)
The problem is the same if the drawing is build in LibO 3.5, saved, then re-loaded.
Comment 3 Laurent BP 2012-03-28 12:30:21 UTC
This issue seems very similar to #fdo47406
https://bugs.freedesktop.org/show_bug.cgi?id=47406
Almost all graphics that have internal circuits are not rending correctly
Comment 4 Regina Henschel 2012-03-29 15:20:24 UTC
The problem occurs, when a classic shape is intersect with a custom shape.
Comment 5 Laurent BP 2012-04-09 14:16:24 UTC
I can NOT reproduce with LibO 3.5.2. This issue looks fixed.

However, the problem with extension gallery 
http://extensions.libreoffice.org/extension-center/gallery-of-danger-signs
is NOT solved. I have to open a new issue :(

Laurent BP
Comment 6 Laurent BP 2012-04-09 14:35:35 UTC
(In reply to comment #5)
> However, the problem with extension gallery 
> http://extensions.libreoffice.org/extension-center/gallery-of-danger-signs
> is NOT solved. I have to open a new issue :(
Issue 48483 opened
https://bugs.freedesktop.org/show_bug.cgi?id=48483
Comment 7 Laurent BP 2012-04-10 13:17:00 UTC
The problem is solved from 3.4.6 to 3.5.2, but not from 3.5.2 to 3.4.6.
Steps to reproduce: simply invert in previous procedure 3.4 and 3.5
1. In LibreOffice 3.5.2 open a new .odg document.
2. Draw three rectangular strips close to each other.
3. Group the strips.
4. Draw a circle on the strips to cover them partially.
5. Select the grouped strips and the circle together. Take intersection of
them, so you'll have three strips with their narrow edges rounded.
6. Select the shape and give it some some rotation from Position and Size.
7. Save it as .odg
8. Open the saved odg document with LibreOffice 3.4.6
9. The drawing is not what you created.
Comment 8 Jean-Baptiste Faure 2012-04-14 23:45:59 UTC
(In reply to comment #7)
> The problem is solved from 3.4.6 to 3.5.2, but not from 3.5.2 to 3.4.6.

Hi Laurent,
Please, have a look at https://bugs.freedesktop.org/show_bug.cgi?id=47406#c29
Maybe I am wrong, but it seems to me that we have the same problem here. 

Best regards. JBF
Comment 9 ign_christian 2013-06-19 09:45:44 UTC
DUPLICATE per comment 3 & comment 8

*** This bug has been marked as a duplicate of bug 47406 ***