Download it now!
Bug 47719 - SLIDESHOW shows Han characters fat and ugly with Hardware Acceleration activated
Summary: SLIDESHOW shows Han characters fat and ugly with Hardware Acceleration activated
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: All Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 51051 (view as bug list)
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2012-03-22 07:14 UTC by Cheng-Chia Tseng
Modified: 2015-01-07 15:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The sample presetation. (1.43 MB, application/vnd.oasis.opendocument.presentation)
2012-03-22 07:14 UTC, Cheng-Chia Tseng
Details
The screenshot of design preveiw, Hardware Acceleration activated and disabled comparison. (421.04 KB, image/png)
2012-03-22 07:15 UTC, Cheng-Chia Tseng
Details
“AR PL UMing TW” bold font Impress odp file (20.81 KB, application/vnd.oasis.opendocument.presentation)
2012-06-01 18:06 UTC, hayno
Details
“AR PL UMing TW” bold font in Impress screenshot (68.31 KB, image/png)
2012-06-01 18:08 UTC, hayno
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cheng-Chia Tseng 2012-03-22 07:14:12 UTC
Created attachment 58872 [details]
The sample presetation.

With sample document (as attachment), Han characters on first slide will be shown too fat and ugly during slide show with "Hardware Acceleration" activated.

Steps how to reproduce with "LibreOffice 3.5.1" on Fedora x64 plaform.

1. open document, activate menu 'Tools -> Options -> Viewing -> 
   Hardware acceleration' if necessary
2. start the slideshow with first slide and compare text view with text view in 
   edit mode. 
   Expected: no difference
   Actual: During slideshow, Han characters became fat (looks like many strokes overlapping each other) and ugly.

The ugly text also is visible with presentations created from the scratch.
Comment 1 Cheng-Chia Tseng 2012-03-22 07:15:34 UTC
Created attachment 58873 [details]
The screenshot of design preveiw, Hardware Acceleration activated and disabled comparison.
Comment 2 sasha.libreoffice 2012-03-25 23:14:35 UTC
Thanks for bugreport
Reproduced in 3.3.4 and 3.5.1 on Fedora 64 bit (Linux only problem)
Comment 3 V字龍(Vdragon) 2012-04-26 07:51:49 UTC
Reproduced in 3.5.2 on Linux Mint 12(32 bit)
Comment 4 hayno 2012-06-01 18:06:00 UTC
Created attachment 62402 [details]
“AR PL UMing TW” bold font Impress odp file
Comment 5 hayno 2012-06-01 18:08:07 UTC
Created attachment 62403 [details]
“AR PL UMing TW” bold font in Impress screenshot

If Hardware Acceleration is activated ,“AR PL UMing TW” bold font becomes ugly.

Hardware Acceleration will cause problem when displaying “AR PL UMing TW” bold font.

This problem has been exist in OpenOffice and LibreOffice on Linux.
Comment 6 hayno 2012-06-01 18:47:01 UTC
uming.ttc can be downloaded from 
http://packages.debian.org/squeeze/all/ttf-arphic-uming/download
Comment 7 vitriol 2012-06-13 22:11:05 UTC
*** Bug 51051 has been marked as a duplicate of this bug. ***
Comment 8 QA Administrators 2015-01-05 17:51:06 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.3.5 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
Comment 9 Cheng-Chia Tseng 2015-01-07 14:15:26 UTC
The issue solved at LibreOffice 4.3.5.2 on Fedora 21.

If the problem appears again, please reopen this bug report.
Comment 10 V字龍(Vdragon) 2015-01-07 15:15:39 UTC
I can't reproduce the bug on 4.3.5.2 too.