Bug 47768 - FILESAVE: DOCX - Table borders exported using newer OOXML tags so not understood by Word 2007
Summary: FILESAVE: DOCX - Table borders exported using newer OOXML tags so not underst...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Tables OOXML-2007
  Show dependency treegraph
 
Reported: 2012-03-23 06:47 UTC by Sadi
Modified: 2017-07-05 09:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
a problematic sample DOCX file (3.68 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-03-23 06:50 UTC, Sadi
Details
screenshot of error message (27.43 KB, image/png)
2012-03-23 06:52 UTC, Sadi
Details
ODT file saved as DOC, opened by MS Word 2007, and saved as DOCX (10.71 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-03-25 12:38 UTC, Sadi
Details
ODT file saved as DOC, opened by MS Word 2007, and saved as DOCX (10.59 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-03-25 12:48 UTC, Sadi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sadi 2012-03-23 06:47:01 UTC
When user tries to save an ODT file containing a table in DOCX format, the resultant file cannot be opened by Microsoft Office 2007.

The Error Message reads:
============================================================================
The Office Open XML file SampleFile.docx cannot be opened because there are problems with the contents.

Details
--------------------------
System error: -2147467259.
Location: Part: /word/document.xml, Line: 2, Column:724
============================================================================
Comment 1 Sadi 2012-03-23 06:50:47 UTC
Created attachment 58926 [details]
a problematic sample DOCX file
Comment 2 Sadi 2012-03-23 06:52:02 UTC
Created attachment 58927 [details]
screenshot of error message
Comment 3 Christopher Yeleighton 2012-03-25 10:56:45 UTC
System error: -2147467259 is Unspecified Error (E_FAIL), which really does not tell us anything.

The XML is well-formed.

The offending instruction is 

  <w:start w:color="000000" w:space="0" w:sz="2" w:val="single"/>

and there does not seem to be anything wrong with it by itself.  
However, the tag does seem inappropriate for a border specification.

Could you provide an equivalent document that Microsoft Word does open?
Comment 4 Sadi 2012-03-25 12:38:31 UTC
Created attachment 59018 [details]
ODT file saved as DOC, opened by MS Word 2007, and saved as DOCX

When the original ODT file is saved as DOC (instead od DOCX), MS Word 2007 does open it, but it fails to display any borders at all, although they are perfectly visible in Writer both in ODT and DOC formats.
Comment 5 Sadi 2012-03-25 12:48:43 UTC
Created attachment 59022 [details]
ODT file saved as DOC, opened by MS Word 2007, and saved as DOCX

Sorry, these attachment comments should swap places...
And the comment below should actually be for the other file (bordered)
-----------------------------------------------
When MS Word 2007 opens the DOC file without displaying its borders, it is possible to add borders and save it as DOCX, and then MS Word 2007 can open this DOCX file with borders visible.
Comment 6 Sadi 2012-05-04 01:23:07 UTC
This bug is no longer present in LibreOffice 3.5.3
Comment 7 Yousuf Philips (jay) (retired) 2017-05-14 07:41:21 UTC
So the issue here was that the OOXML standard understood by word 2007 requires borders on the left and right to be tagged as '<w:left>' and '<w:right>', while the newer OOXML standard uses '<w:start>' and '<w:end>'.