Bug Hunting Session
Bug 47821 - text in draw does not fit to frame
Summary: text in draw does not fit to frame
Status: RESOLVED DUPLICATE of bug 34467
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-24 14:38 UTC by merkursports
Modified: 2012-06-23 04:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example with working stretching text object (11.81 KB, application/vnd.oasis.opendocument.graphics)
2012-04-09 13:05 UTC, Piotr Kowalewski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description merkursports 2012-03-24 14:38:33 UTC
First,I have to apologize for my poor English, because I am not a native English spoken, but I will try to do my best to be understandable.

Since I have used OpenOffice under linux, there is a trouble with trying to stretch text to frame. Before, under windows, text adjusted to frame will be able to stretch dynamically in any direction and any size. 

Meanwhile, under linux, a text frame only can be stretched by steps, alike when you fit against grid, and moreover to be right, this text frame cannot be stretched, it can only be deformed proportionally by steps. More exactly, the frame can be stretched, but text inside did not follow the frame, only by steps.

Another thing, when a picture created under windows is opened under linux, text objects works well. Moreover when this text object is pasted into another draw it works well too.

But today, I have found that both versions, linux and windows, did not work well at this point.
Comment 1 Rainer Bielefeld Retired 2012-03-25 01:28:42 UTC
@reporter:
Thank you for your report – unfortunately important information is missing.
May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem? If you believe that that  is really sophisticated please as for Help on a user mailing list
Please:
- Write a meaningful Summary describing exactly what the problem is
- Attach a sample document (not only screenshot)
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (due to example in Bug 43431)
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- what EXACTLY is unexpected
  -- and WHY do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your PC
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO version and localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document
  –- If you can contribute an OOo Issue that might be useful
  -- everything else crossing your mind after you read linked texts

Even  if you can not provide all demanded information, every little new information might bring the breakthrough.

May be you can test <https://www.libreoffice.org/get-help/bug/> for submitting bug reports?

Please submit different reports for every problem you find
Comment 2 Piotr Kowalewski 2012-04-09 13:05:56 UTC
Created attachment 59696 [details]
Example with working stretching text object
Comment 3 Piotr Kowalewski 2012-04-09 13:07:22 UTC
Hello,
I have the same problem with Windows version (LibeOffice Draw 3.5.2.2).

Just try to do steps "Fitting Text to Frames" from http://help.libreoffice.org/Draw/Adding_Text

It doesn't work, but it worked with earlier versions (I don't know wich version exactly, but I used this function few times before).

When you open old file (created with earlier version LibreOffice Draw) you can still stretch text in frame by resizing the frame, but you cannot create new objects with stretched text like this in attachment.

Best regards,
Piotr Kowalewski
Comment 4 merkursports 2012-04-11 17:54:11 UTC
Comment on attachment 59696 [details]
Example with working stretching text object

When you open an existing document created under older OpenOffice is possible to see that Text follow to the frame.
But when you create a new document is impossible to get text following the frame.
Rather, I have see that a document created under LO but open at earlier OO show that /Format/Text checkbox looks empty, in spite of mark "Adjust to frame" under LO.
Comment 5 Rainer Bielefeld Retired 2012-06-23 04:40:13 UTC
This bug seems to contain a whole bunch of problems, what we can not handle.

I only understand problem described by "Piotr Kowalewski". 
Reducing bug to that problem it's a DUP of "Bug 34467 - FORMATTING Fit to Frame for text boxes is broken", and I mark this one as a DUP of that one.

*** This bug has been marked as a duplicate of bug 34467 ***