Download it now!
Bug 47840 - Version mismatch in the exe files Properties and About dialog
Summary: Version mismatch in the exe files Properties and About dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.1 RC1
Hardware: Other Windows (All)
: medium normal
Assignee: Petr Mladek
URL:
Whiteboard: target:3.5.3 target:3.6.0
Keywords:
: 47845 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-25 05:52 UTC by Pedro
Modified: 2012-04-10 08:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2012-03-25 05:52:42 UTC
Version number in the About dialog and in the exe files Properties under Windows OS has never matched.

This was not so bad under branch 3.4.x since numbering was/is e.g. LibreOffice 3.4.6 OOO340m1 (Build:602) in the About dialog and 3.4.602.500 in the file Properties. 

In the 3.5.x branch (ignoring version 3.5.0 which was released as RC3) you get LibreOffice 3.5.1.2 in the About box and 3.5.0.102 in the Properties

Similarly for the current version 3.5.2RC1 you get LibreOffice 3.5.2.1 and 3.5.0.201 in the Properties.
Comment 1 Jean-Baptiste Faure 2012-03-26 04:57:05 UTC
*** Bug 47845 has been marked as a duplicate of this bug. ***
Comment 2 Not Assigned 2012-04-10 00:01:34 UTC
Petr Mladek committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=47fce99b80310f1d535f79c0f8a0e1363ed09389&g=libreoffice-3-5

match version in about dialog and file properties (fdo#47840)


It will be available in LibreOffice 3.5.3.
Comment 3 Not Assigned 2012-04-10 07:45:32 UTC
Petr Mladek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4045e770193ae632aca7075105dda89686c597d6

use x.y.z version also for desktop integration packages (fdo#47840)
Comment 4 Not Assigned 2012-04-10 08:29:53 UTC
Petr Mladek committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=58e524761aabb4bfc214e0375aaa4ec94b3e8903&g=libreoffice-3-5

use x.y.z version also for desktop integration packages (fdo#47840)


It will be available in LibreOffice 3.5.3.