Bug Hunting Session
Bug 47888 - EDITING: Spell & grammar dialog box does not highlight punctuation in error
Summary: EDITING: Spell & grammar dialog box does not highlight punctuation in error
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Spell-Checking-Dialog
  Show dependency treegraph
 
Reported: 2012-03-26 02:22 UTC by Wyndham Clampett
Modified: 2017-08-15 13:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing lack of highlighting (165.99 KB, image/jpeg)
2012-03-26 02:22 UTC, Wyndham Clampett
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wyndham Clampett 2012-03-26 02:22:04 UTC
Created attachment 59052 [details]
Screenshot showing lack of highlighting

Problem description: 
Spell & grammar dialog box does not highlight punctuation in error.This makes it sometimes difficult to see where the error is.

Steps to reproduce:
1. Start spellcheck
2. Punctuation error found and dialog box shown
3. See screenshot

Current behavior:
A message is displayed advising of the error - this is nice.

No highlighting in the spell & grammar dialog box, to show where the error is.

On a large monitor with a high resolution, the text in the dialog box can be a little small to read easily and without any highlighting, even more difficult to spot.

Expected behavior:
Highlight the surrounding words.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.65 Safari/535.11
Comment 1 Joel Madero 2012-08-30 01:10:17 UTC
I can't even get spell check to show there is punctuation error. Are you still seeing the bug in this same way or is your LibO not even seeing punctuation errors at all? I did a test where I had:

This is a good sentence. .This is not. I'd imagine that the second . should be seen but it's not. Please let me know so I can properly prioritize this one, could be raised to a higher level as it makes creating professional quality work much more difficult
Comment 2 A (Andy) 2012-12-26 20:05:25 UTC
reproducible with LO 3.6.4.3. (Win7 Home, 64bit)

I have chosen as a sample text the one in the below mentioned second comment "This is a good sentence. .This is not".

Bug 1: This bug seems at first glance to be a little bit strange, but maybe it explains the second comment in this bug report (?).  Open WRITER and there choose for instance German as a language for the document.  Then copy the sample text into the document (without a further space and enter key pressing).  Afterwards, select the sentence and choose English (UK) and you will see a blue wave line for the full stop mistake.  But if you choose English (USA) no full stop mistake will be shown, even when starting the SPELLING AND GRAMMAR check.  The mistake in US English will only be shown after pressing the enter key and then also the SPELLING AND GRAMMAR check will find this error.  This seems to my mind to be inconsistent.

Bug 2 (reported below): If you look at the text in the WRITER document, then the error will be highlighted correctly with a blue wave line.  If you open the SPELLING AND GRAMMAR check, then the error will also be highlighted.  But this is not really recognisable because the wrong full stop is in blue and only a very little bit larger than normal and this you can not really recognise.  Therefore, there should be another solution like the wave line and/or error highlighting in another better recognisable colour and not in blue, because it is more difficult to distinguish blue from black than for instance red from black.  But red is already used for spelling errors, therefore, we maybe have to look for another colour for grammar mistakes or also red?  Together with a wave line it would be easier to see the mistake.

Bug 3: The offered correction in the SPELLING AND GRAMMAR check is another full stop.  This leads to "This is a good sentence.. .This is not." which is also not correct.
Comment 3 QA Administrators 2015-01-05 17:51:12 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2016-01-17 20:02:11 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-03-06 13:50:21 UTC Comment hidden (obsolete)
Comment 6 Jean-Baptiste Faure 2017-08-15 13:32:29 UTC
I tried with the sentence "This is a good sentence. .This is not" in LO 5.4.2.0.0+ under Ubuntu 16.04. The spell & grammar dialog box show the faulty punctuation by showing it bold.
The suggestion is erroneous but that is another story.

Closing as WorksForMe. Feel free to reopen if you disagree.

Best regards. JBF