Bug Hunting Session
Bug 47915 - EDITING: text adjusted to frame cannot be stretched, under linux and windows
Summary: EDITING: text adjusted to frame cannot be stretched, under linux and windows
Status: RESOLVED DUPLICATE of bug 34467
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-26 09:53 UTC by merkursports
Modified: 2012-07-06 08:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The picture show 2 LO draw pages, the upper window show a text that cannot be stretched in spite of a stretched frame. The picture under show a draw created under OO3.2, but opened at LO working properly when a text frame is stretched (246.48 KB, image/jpeg)
2012-03-26 09:53 UTC, merkursports
Details
file for test stretch text block (9.00 KB, application/vnd.oasis.opendocument.graphics)
2012-07-06 07:43 UTC, merkursports
Details

Note You need to log in before you can comment on or make changes to this bug.
Description merkursports 2012-03-26 09:53:18 UTC
Created attachment 59080 [details]
The picture show 2 LO draw pages, the upper window show a text that cannot be stretched in spite of a stretched frame. The picture under show a draw created under OO3.2, but opened at LO working properly when a text frame is stretched

Problem description: 

Steps to reproduce:
1. /format /text/adjust to frame
2. write a text....
3. try to strecht pulling from corners with mouse

Current behavior: characters cannot be stretched, they do not follow the frame, 

Expected behavior: character should follow frame size

Platform (if different from the browser): Before it was a trouble only in linux, but today is a problem in both. I have tested several linux distributions Mandriva, Fedora and Opensuse, since so many years ago, all of them fail at this point. Only Fedora 14 version work properly. Today untill windows version fail too.

Moreover, a draw file created under windows (older versions, or OO version) but opened either under linux or latest LO windows version, work properly and follow expected behavior, text along frame can be stretched. In the same way a text object from this file could be pasted into a new draw file either linux or windows version and work properly too
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 1 sasha.libreoffice 2012-06-21 02:24:55 UTC
Thanks for bugreport
Reproduced in 3.3.4, 3.5.4 and 3.6 beta 1 on Fedora 64 bit
IMHO in 3.2.1 it was also reproducible.

Text size can be easily reduced automatically, but it is impossible to enlarge it.

From fact that document created in OOO correctly opens in LO I guess that problem is in UI. Or there was something like "Enlarge font to fit to frame" or current option "Fit to frame" was working in both directions (shrink/enlarge).

@ merkursports@yahoo.com
Please, attach odp document from OOo with working stretching of frame (if possible) for testing.
Comment 2 Rainer Bielefeld Retired 2012-06-23 04:51:09 UTC
Known problem!

*** This bug has been marked as a duplicate of bug 34467 ***
Comment 3 merkursports 2012-07-06 07:43:41 UTC
Created attachment 63893 [details]
file for test stretch text block
Comment 4 sasha.libreoffice 2012-07-06 08:30:45 UTC
Thanks for attachment. For producing this effect we should save drawing document as fodt, open it in text editor and do following:
Remove this:
draw:auto-grow-height="false"
draw:fit-to-size="shrink-to-fit"
And add this:
draw:fit-to-size="true"

So, as I can see, Draw and Impress UI not fully corresponds with ODF format. May be someone changed savin/opening of document, but not updated UI.
Comment 5 sasha.libreoffice 2012-07-06 08:36:08 UTC
Correction: only draw:fit-to-size="shrink-to-fit" needed to be changed