Bug Hunting Session
Bug 47957 - dung out laughable cui color options code ...
Summary: dung out laughable cui color options code ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium normal
Assignee: Uray M. János
URL:
Whiteboard: target:3.7.0
Keywords: difficultyBeginner, easyHack, skillCpp, topicCleanup
: 48919 51204 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-27 11:23 UTC by Michael Meeks
Modified: 2015-12-15 23:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2012-03-27 11:23:51 UTC
If you fire up your editor and read:

cui/source/options/optcolor.cxx ...

This is the tools->options->appearance widget.

At a minimum it is necessary to laugh at: ColorConfigCtrl_Impl(this, CUI_RES( CT_COLORCONFIG ) )) - and the hideous member functions, and laborious code in there.

We should have a little loop to construct the array of widget pointers on the heap: new FixedText(...); etc.

We should use a struct to store each of the three elements, instead of multiple separate arrays, we should simplify all the logic in this big heap.


It'd also be a nice idea (as a 2nd, optional thing) to re-use a standard widget if there is one, instead of this custom, hacked-up, manually scrolled mess :-)

Thanks for dunging it out !
Comment 1 Daniel Bankston 2012-03-29 15:37:51 UTC
Hi, Michael,

Did you mean ColorConfigWindow_Impl?  Or least both ColorConfigCtrl_Impl AND ColorConfigWindow_Impl?
http://opengrok.libreoffice.org/xref/core/cui/source/options/optcolor.cxx


Thanks.
Comment 2 Daniel Bankston 2012-03-29 22:15:24 UTC
Hi, Michael,

Nevermind, I've been looking at the code more.  I'll see what I can come up with.
Comment 3 Daniel Bankston 2012-04-05 07:47:16 UTC
Hi,

Sorry, I got distracted with other EasyHacks.  I'm setting this back to new in case someone else wants to work on it before I get back to it.
Comment 4 Andras Timar 2012-04-20 02:58:45 UTC
*** Bug 48919 has been marked as a duplicate of this bug. ***
Comment 5 Florian Reisinger 2012-05-18 09:28:51 UTC
Deleted "Easyhack" from summary.
Comment 6 Andras Timar 2012-07-16 09:49:44 UTC
*** Bug 51204 has been marked as a duplicate of this bug. ***
Comment 7 Not Assigned 2012-07-23 13:57:19 UTC
Uray M. Janos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2ca73bfbf46332bcd52619e2e82e6a2a744eaa8c

fdo#47957 refactoring and simplifying the color config settings
Comment 8 Robinson Tryon (qubit) 2015-12-15 23:50:45 UTC
Migrating Whiteboard tags to Keywords: (EasyHack,DifficultyBeginner,SkillCpp,TopicCleanup)
[NinjaEdit]