Download it now!
Bug 48168 - Menus positioned incorrectly on multi-monitor displays
Summary: Menus positioned incorrectly on multi-monitor displays
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: x86-64 (AMD64) Linux (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 43994 47413 48480 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-01 19:46 UTC by Peter Bayley
Modified: 2017-06-03 12:54 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots showing Writer running on each of three monitors (144.33 KB, image/png)
2012-04-01 19:46 UTC, Peter Bayley
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Bayley 2012-04-01 19:46:54 UTC
Created attachment 59359 [details]
Screenshots showing Writer running on each of three monitors

I run three monitors arranged horizontally.  When I run Writer on the
Left-hand monitor the various menus act properly.  When I move the Writer
main window to the Center Monitor, the menus appear on the Right-hand
monitor and even sub-menus are on the hard left edge of the monitor so they
are placed over each other.  When I place the Writer main window on the
Right-hand monitor, the menus appear on the left-hand edge of the right
monitor and are also placed over each other.

I would think the problem lies in an assumption, somewhere in  the code,
that there are, at most, two monitors side by side and menu position
calculations are being made accordingly.  Below are screenshots of the
Writer window on the three monitors.

System: Ubuntu 11.04 Natty Narwhal
Writer LibreOffice 3.5.1.2 Build ID 350m1(Build 102)
Comment 1 Paweł Rumian 2012-04-16 07:06:11 UTC
I can confirm the problem on a Gentoo with a 3 monitor configuration, using open source ATI drivers and very clean monitor configuration done via xrandr (clean == pure RandR protocol, no tricks, no proprietary hacks).

I am using libreoffice-3.5.2.2 compiled from sources on Gentoo.
The relevant bugreport is here:
https://bugs.gentoo.org/show_bug.cgi?id=408793

There is another report of this issue:
https://bugs.freedesktop.org/show_bug.cgi?id=48480

And also in another distros:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/974900
Comment 2 Paweł Rumian 2012-04-16 07:10:31 UTC
*** Bug 48480 has been marked as a duplicate of this bug. ***
Comment 3 Anderson Medeiros Gomes 2012-04-16 16:10:28 UTC
*** Bug 43994 has been marked as a duplicate of this bug. ***
Comment 4 efstratios.charitos 2012-05-09 05:55:02 UTC
I can confirm this bug. Ubuntu 64bit 12.04, fresh install, 3 monitors, ATI 12.3 catalyst.
Comment 5 efstratios.charitos 2012-05-11 11:53:02 UTC
Same problem here with 3.5.3 triple monitor, Ubuntu 12.04 64 bit
Comment 6 Samuel 2012-05-12 08:35:37 UTC
It is impossible for me to upgrade from 3.4.x -> 3.5.x with this bug :-(
Comment 7 Jack Kelly 2012-05-13 04:01:23 UTC
I'm getting the same problem on Ubuntu 12.04 and LibOffice 3.5.3.2 (ubuntu repositories). LO worked fine on Ubuntu 11.10.

Interestingly, the problem seems to be dependent on the monitor layout configuration I specify in System Settings > Displays.  (I have a 1920x1200 monitor connected to my 1600x900 laptop).  If my second monitor is configured directly above the laptop monitor such that the two monitors have their left edges aligned then the problem goes away.

However, if my second monitor is positioned so its left edge is not aligned with my laptop monitor's left edge then I can't get access to the File, Edit, View, Insert of Format menus (the other menus work fine); and LO crashes soon after I try to access any of the inaccessible menus.

A screenshot of this second configuration is available here: 

http://xlk.org.uk/LOscreenshot.png

In the screenshot, I'm trying to open the File menu.
Comment 8 efstratios.charitos 2012-05-13 08:36:19 UTC
Same problem here. 12.04 64bit, 3.5.3, fglrx 12.3.
Comment 9 Bernhard Rohrer 2012-05-13 10:00:48 UTC
Same problem here, Catalyst 12.3
Comment 10 Jack Kelly 2012-05-14 04:48:53 UTC
Just to emphasise: this is, in my opinion, a serious bug.  It pretty much renders LO unusable.

Given the number of people who have reported this bug, I'm going to go ahead and change the status of this bug from UNCONFIRMED to NEW although I have no idea if I'm following the correct etiquette (I'm not a LO developer, I'm just a user).
Comment 11 Jack Kelly 2012-05-15 12:34:17 UTC
I just wanted to write again with a more detailed description of the issue I'm experiencing.  I'm a little nervous that perhaps we're conflating several different problems into a single bug report; but probably not.  So I wanted to describe my situation in as much detail as possible...

THE PROBLEM
(I'll use Calc as a specific example but similar problems are present in all LibreOffice apps)

If I click on the File, Edit, View, Insert or Format menu, the menu does not open.  Instead I see the artefact show in this screenshot http://xlk.org.uk/LOscreenshot.png near the File menu.

If I right-click on any cell in columns A, B, C or D then I see the exactly the same menu problem.

After using LibreOffice for a few minutes it usually crashes.

MY SETUP
LibOffice 3.5.3.2 (ubuntu
repositories)
Ubuntu 12.04 64bit with dual monitors configured as shown in http://xlk.org.uk/LOscreenshot.png

"FIXES" THAT WORK FOR ME (none of which are satisfactory)
* If I disable my second monitor then LibreOffice works fine
* If I enable both of my monitors and position the 2nd monitor so the left sides of both monitors are aligned and the 2nd monitor is directly above the primary monitor then it works fine.
Comment 12 Jack Kelly 2012-05-21 02:31:19 UTC
A further update: Uninstalling "libreoffice-gtk" fixes the menu problem for me (but LibreOffice looks rather ugly without GTK+ integration... but at least it works).
Comment 13 Jack Kelly 2012-05-21 08:14:49 UTC
uninstalling "libreoffice-gtk" also fixes the problem for this guy: http://askubuntu.com/a/140152/62337
Comment 14 Bernhard Rohrer 2012-05-21 08:34:20 UTC
I am at least not getting the stability issue, as long as I run my libreoffice on the left screen it works fine.
Comment 15 Paweł Rumian 2012-05-21 09:37:46 UTC
Yes, it is defintely a GTK issue. If you read bugreport on the Gentoo bugzilla (linked in comment #1) you will see that launching LO with SAL_USE_VCLPLUGIN=gen 'fixes' the issue.

I am also rising the importance of this bug, as it really makes LO very hard to use in multihead environments.
Comment 16 Samuel 2012-05-25 09:04:17 UTC
Is the problem in the next version (3.5.4) solved?
Comment 17 Paweł Rumian 2012-06-06 10:29:04 UTC
*** Bug 47413 has been marked as a duplicate of this bug. ***
Comment 18 Bernhard Rohrer 2012-06-10 05:35:34 UTC
(In reply to comment #16)
> Is the problem in the next version (3.5.4) solved?

Joker. I have yet to see any comment by a LO developer on this bug, so it clearly has not been addressed yet.
Comment 19 Bernhard Rohrer 2012-06-10 05:37:35 UTC
Apologies. Pawel clearly is a developer.
Comment 20 Bernhard Rohrer 2012-06-10 05:41:25 UTC
The relevant launchpad bug is here BTW: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/974900
Comment 21 Paweł Rumian 2012-06-10 10:50:09 UTC
(In reply to comment #19)
> Apologies. Pawel clearly is a developer.

Unfortunately not, but this bug is very important to me and this is why I am tracking similar issues and try to centralize all the reports (also by finding duplicates). 

I also find it VERY weird that no developer commented on this issue. I was hoping that bug with so many duplicates and of relatively high importance will be at least assigned, especially that first report is over half a year old.

Oh, and the launchpad bug was linked in comment #1, but of course there is nothing wrong in reposting it, as it confirms that at least 12 other people are affected :)
Comment 22 Samuel 2012-06-10 11:41:36 UTC
> I also find it VERY weird that no developer commented on this issue. I was
> hoping that bug with so many duplicates and of relatively high importance will
> be at least assigned, especially that first report is over half a year old.

I can not understand this, since report of the bug we have LibreOffice version 3.5.2, 3.5.3, 3.5.4.

At the moment, that is _my_ opinion, LibreOffice 3.5.x is not ready for the business.

I have no desire at the moment to test new versions / release candidates of LibreOffice because such important bugs won't fix. :-(
Comment 23 sasha.libreoffice 2012-06-14 23:31:29 UTC
Slightly resembles this:
Bug 46469 - : Menu displays on dual-monitor systems too far to the left
Comment 24 Ruslan Kabatsayev 2012-06-15 05:46:24 UTC
Marking as regression since it is reported to not exist in 3.4.x
Comment 25 Ruslan Kabatsayev 2012-06-15 16:47:07 UTC
Someone please check if this patch fixes this bug:
https://bugs.freedesktop.org/attachment.cgi?id=63092&action=edit
Comment 26 David Tardon 2012-06-20 01:57:52 UTC

*** This bug has been marked as a duplicate of bug 46469 ***
Comment 27 Timo A. Hummel 2012-10-24 14:55:55 UTC
Still reproducible on 3.5.4.2, which should include the fix from bug 46469.

Ruslan: I cannot test source patches, is there some way you can provide a binary to test against?
Comment 28 Ruslan Kabatsayev 2012-10-24 17:09:10 UTC
(In reply to comment #27)
> Still reproducible on 3.5.4.2, which should include the fix from bug 46469.
> 
> Ruslan: I cannot test source patches, is there some way you can provide a
> binary to test against?

According to [1], this should be fixed in 3.5.5.

[1] http://lists.freedesktop.org/archives/libreoffice/2012-June/033620.html
Comment 29 Bernhard Rohrer 2012-10-25 02:22:29 UTC
I am running 3.6 and it is certainly fixed in there
Comment 30 Ruslan Kabatsayev 2013-01-03 00:42:02 UTC
Since there's been no posts since last confirmation of the bug being fixed, I close it as FIXED.
Comment 31 vihsa 2017-06-03 12:54:23 UTC
according to comment 29, verified, hence status change.