Bug Hunting Session
Bug 48193 - RTF import is completely messed up now
Summary: RTF import is completely messed up now
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: All Windows (All)
: medium major
Assignee: Miklos Vajna
URL:
Whiteboard: target:3.6.0 target:3.5.4
Keywords: filter:rtf, regression
Depends on:
Blocks:
 
Reported: 2012-04-02 05:50 UTC by Bjørn K Nilssen
Modified: 2015-12-17 12:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
An example (deleted)
2012-04-02 05:50 UTC, Bjørn K Nilssen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bjørn K Nilssen 2012-04-02 05:50:12 UTC
Created attachment 59378 [details]
An example

After just upgrading to LO 3.5.1 I found that RTF files that imported fine earlier today is now completely messed up.
These are files generated by Legacy Family Tree genealogoy software.
They contain index tags on all names, which is now not imported at all.
Many RTF docs also imports as mostly blank pages.
Comment 1 s-joyemusequna 2012-04-11 11:37:57 UTC
Confirmed (Windows XP, Vista 64).

Works fine with LibO 3.4.5, does not work with LibO 3.5.2 => REGRESSION
Comment 2 Not Assigned 2012-04-25 03:02:24 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bec0bab00eeed78ccdb7065554dcf9e898f499fa

fdo#48193 fix RTF import of fields without a result
Comment 3 Miklos Vajna 2012-04-25 03:19:07 UTC
Should be fixed in master now, marking as resolved. Added to my -3-5 cherry-pick request queue.
Comment 4 Miklos Vajna 2012-04-25 03:19:37 UTC
Oops, forgot to assign first.
Comment 5 Not Assigned 2012-05-08 02:29:40 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9b03e5c64482a4725459daa5ccc16fa686a3bffb&g=libreoffice-3-5

fdo#48193 fix RTF import of fields without a result


It will be available in LibreOffice 3.5.4.
Comment 6 s-joyemusequna 2012-05-19 01:21:03 UTC
Tested with LOdev 3.6 (master - 18-May-2012 02h44 x86@6-fast; Build ID: 8b1d29b) under Windows Vista 64.

It looks good, but line 3 "[ Fjern disse tre linjene. ]" on page one should be probably on the first page, not on the second. The section break is after that line.
Comment 7 Bjørn K Nilssen 2012-08-24 01:06:07 UTC
Could someone please remove the attachment RTF file I posted?

It turns out that its content is now indexed and easily found by Google, which is not good at all, because it contains personal/private data about living persons, which isn't legal to publish on the net.
If I had known that it would be public like that I would never have posted that particular file!
But now I can't find a way to delete/remove it.
Comment 8 Bjørn K Nilssen 2012-08-24 01:26:25 UTC
Comment on attachment 59378 [details]
An example

Removed
Comment 9 Bjørn K Nilssen 2012-08-24 01:27:56 UTC
Comment on attachment 59378 [details]
An example

Removed
Comment 10 Bjørn K Nilssen 2012-08-24 01:29:35 UTC
Comment on attachment 59378 [details]
An example

Removed

se tre linjene. ]
>\par }
Comment 11 Bjørn K Nilssen 2012-08-24 07:50:13 UTC
Comment on attachment 59378 [details]
An example

Removed

se tre linjene. ]
>\par }
Comment 12 Tollef Fog Heen 2012-09-02 19:25:30 UTC
The content of attachment 59378 [details] has been deleted by
    Tollef Fog Heen <tfheen@err.no>
who provided the following reason:

Private

The token used to delete this attachment was generated at 2012-09-02 19:25:22 UTC.
Comment 13 Robinson Tryon (qubit) 2015-12-17 12:05:52 UTC
Migrating Whiteboard tags to Keywords: (filter:rtf)
Replace rtf_filter -> filter:rtf.
[NinjaEdit]