Bug 48275 - EDITING: Ctrl-D does not work if selected only one cell
Summary: EDITING: Ctrl-D does not work if selected only one cell
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-03 22:38 UTC by Vlad
Modified: 2013-07-08 02:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vlad 2012-04-03 22:38:26 UTC
Problem description: 
Ctrl-D does not work if selected only one cell

Steps to reproduce:
1. cell A1=1
2. select cell A2
3. click Ctrl-D and nothing happen

Current behavior:
Ctrl-D does not work if selected only one cell

Expected behavior:
Will be useful if Ctrl-D will fill down upper cell to current if selected only one cell or only one row. 

Platform (if different from the browser): 
Ubuntu 11.10
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 1 Rainer Bielefeld Retired 2012-04-09 00:36:36 UTC
Might be this would be a useful feature, but IMHO not a Bug

I see the requested function rudimentary with parallel  installation of  Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 4495824-6299bf6-ec8645]" (tinderbox: Win-x86@6-fast pull time 2012-04-08 00:03:52): 
a)If the cell cursor is below a cell with contents, 
b) <control+d> will fill selected cell with contents from cell above. 
c) But not, if empty cells are between.

'c' fills the selcted cell with "Empty" contents from cell above, you see that with 'Undo' after 'c'.

This 'Fill with neighbor cell contents' alos works from Edit menu and there for all ifll directions.

@Vlad
Please explain 
- why you believe that it's useful (Competitor's behavior, ...)
- why you also want that for fill down, not for other fill directions
Comment 2 Arno Teigseth 2012-04-12 11:23:09 UTC
I support this as an enhancement, but I think it's already done. This worked for me after rebuilding LO tonight (git 11 apr 2012)

Reasons for keeping this enhancement:
-People are used to it from Exsell

steps to reproduce working behaviour:

1 A1=1
2 select A2
3 Press Ctrl+D. Result: A2=A1. 

Works with formulas, too.
Just like you did "arrow up, Ctrl+C, arrow down, ctrl+v"

It also works if you select a range like A1:E16 and press Ctrl+D.
Then all the topmost cells in the selection are copied down into the rest of the selected cells.



Ctrl+R doesn't work (copy right). But that's another story, and I haven't heard of anyone using it in Exsell even (but it exists there).

best
Arno
Comment 3 Arno Teigseth 2012-04-12 11:23:55 UTC
fixed in MASTER somewhere before 11 april 2012.