Bug Hunting Session
Bug 48279 - FILEOPEN
Summary: FILEOPEN
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-04 00:50 UTC by Herbert Post
Modified: 2012-07-08 10:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
This is the document that creates the error on linux (607.36 KB, application/vnd.ms-powerpoint)
2012-04-05 01:20 UTC, Herbert Post
Details
These are the extensions that are installed. (by default) (127.01 KB, image/png)
2012-04-05 01:21 UTC, Herbert Post
Details
bt with symbols (10.87 KB, text/plain)
2012-04-06 14:14 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Herbert Post 2012-04-04 00:50:30 UTC
A powerpoint presentation created in PowerPoint 2010 but saved in the
PowerPoint 97/2003 .ppt format.
No problem to open on OSx with version 3.5.1.2 Build ID: dc9775d-05ecbee-0851ad3-1586698-727bf66
But simpress (3.5.1.2 same build number as OSx version) crashes on Ubuntu 12.04 Beta 2 (Linux utwks04035 3.2.0-21-generic #34-Ubuntu SMP Fri Mar 30 04:25:35 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux) updated with the following error message:

(soffice:3605): LIBDBUSMENU-GLIB-WARNING **: Translation has an invalid value 'lnr' for default text direction.  Defaulting to left-to-right.
terminate called after throwing an instance of 'libvisio::EndOfStreamException'

Because the file has some sensative information I would rather not attach it.
Comment 1 Julien Nabet 2012-04-04 12:51:42 UTC
Could you try with a brand new LO profile ?
Have you got any LO extension ?
Would it be possible to remove the sensitive information and attach the file ?
Comment 2 Herbert Post 2012-04-05 01:20:29 UTC
Created attachment 59506 [details]
This is the document that creates the error on linux
Comment 3 Herbert Post 2012-04-05 01:21:53 UTC
Created attachment 59507 [details]
These are the extensions that are installed. (by default)

I've done a test with a new LO profile but the result was the same.
Comment 4 Herbert Post 2012-04-05 05:44:29 UTC
After updating to 3.5.2.2 (build 281b639-6baa1d3-ef66a77-d866f25-f36d45f) 
on both OSx and Linux on both platforms Simpress crashes now with the attached document.
Linux version now crashes with this error message:
terminate called after throwing an instance of 'libvisio::EndOfStreamException'
Comment 5 Julien Nabet 2012-04-06 14:14:54 UTC
Created attachment 59605 [details]
bt with symbols

I reproduced the crash on 3.5 branch with pc Debian x86-64.
I attached the bt with symbols.

The file seems to include a visio part. Is there a Visio file linked to the powerpoint ?
Comment 6 Valek Filippov 2012-05-24 19:00:38 UTC
PowerPoint2010 does not open an attached file.
It doesn't look like properly made OLE container, as a result libgsf exits because of the failed assertion, LO crashes.

I believe it's not related to any visio docs embedded into presentation.
Probably libvisio has to be improved to exit gracefully if some bullshit has been received on input.
Comment 7 Valek Filippov 2012-07-08 10:05:20 UTC
Attached file seems to be corrupted.
Crash in libvisio for corrupted files was fixed in another bug.