Download it now!
Bug 48291 - [EDITING] Auto insert copied rows (insert blank rows + paste content as a single command)
Summary: [EDITING] Auto insert copied rows (insert blank rows + paste content as a sin...
Status: RESOLVED DUPLICATE of bug 39936
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-04 05:09 UTC by Mahir B. Asut
Modified: 2020-04-07 12:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mahir B. Asut 2012-04-04 05:09:45 UTC
This is a feature request.

Copying rows for the purpose of inserting them somewhere else (rowwise) is difficult. The default behavior is to insert blank rows (as much as needed) first.

A menu item (and the code behind of course :) like "Paste as Insert" will do the job if it will open as much blank rows as needed an then copy the rows into them automagically...
Comment 1 Joel Madero 2012-07-15 18:17:52 UTC
Verified that this isn't available in Version 3.7.0.0.alpha0+ (Build ID: 21f8c28), marking as NEW, leaving as Medium priority. Thanks for the suggestion
Comment 2 Kevin 2017-05-22 23:08:51 UTC
This basic Excel feature is still missing in Calc 5.3.2.2 - five years after then initial report.

I'm not privy to the spec for this project, but I feel adamantly that the baseline starting point for Calc should have been to reproduce that which is good about Microsoft Excel, and that Calc's ultimate raison d'être should be to alleviate the pain of what's bad about Excel. Excel's right-click command "Insert Copied Rows" is powerful, extremely useful, and bug free. It enables you to retain vast amounts of formatting and we know that formatting is the weakest and most unintuitive aspect of Calc.

How did the development process not go through a phase of simply creating a bug-free Excel, and then adding new features? How could such positive feature as "insert copied cells" not have been added? Am I missing the whole point of the Libre Office project? Was its only goal to provide a free alternative or was it meant to provide something much more important - a truly elegant spreadsheet editor?
Comment 3 Kevin 2017-05-22 23:10:55 UTC
What I mean to ask is: Is achieving feature-equality with Microsoft Excel NOT part of the spec?
Comment 4 Xisco Faulí 2019-11-29 13:27:15 UTC
Changing priority back to 'medium' since the number of duplicates is lower than 5
Comment 5 Timur 2020-04-07 10:36:27 UTC

*** This bug has been marked as a duplicate of bug 39936 ***