Bug 48323 - Marking some rows of a table not possible using select table row
Summary: Marking some rows of a table not possible using select table row
Status: RESOLVED DUPLICATE of bug 35829
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.1 RC1
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-04-05 02:04 UTC by Florian Reisinger
Modified: 2012-04-05 05:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example document (14.83 KB, application/vnd.oasis.opendocument.text)
2012-04-05 02:04 UTC, Florian Reisinger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Reisinger 2012-04-05 02:04:45 UTC
Created attachment 59512 [details]
Example document

Hi!
1) Open example document or create one with a very long table
2) Try to select the idioms ( the first line in the example document is a heading )
3) Select using "select table row" and drag the mouse to the end of the table (a), and the other way round (b).
4)Another way to mark the area is: Place the mouse in the column, where "aeger" is, and holde down the left mouse key till "stark machen" (c). 

Test results:
--- Win XP x86 ---
--Not Working: (a)--
LibreOffice 3.5.2.2 · UI en-US
LibreOffice 3.3.4
OOo 3.2.1

--- Win 7 x64 ---
--Not Working: (a)--
-Installed-
LibreOffice 3.5.2.2 
-Portable-
LibreOffice 3.4.5 
OOO340m1 (Build:502)

--Working: (a)--
-Portable-
OpenOffice.org 3.2.0

---Regression---

Between OO.org 3.2.0 <--> 3.2.1

Thanks to the german ML for their help!

PS: i don't know wheater this is an regression (I mean: Should it be marked as regression) or not...
Comment 1 Rainer Bielefeld Retired 2012-04-05 03:38:33 UTC
Some quick test with "LibreOffice 3.5.2.2 German UI/Locale [Build-ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f] on German WIN7 Home Premium (64bit) did not show anything unexpected.

@Florian:
I do not understand
a) what this has to do with CHART
b) what "select the idioms" might mean. Select 'A2:B40'?
c) what result you see, "not working" tells me nothing
d) what you expect
e) why you expect
Comment 2 Florian Reisinger 2012-04-05 03:42:53 UTC
Sorry, it is writer (AND TABLE)
Here what has been discussed on the German ML:
(Quoting mail of Manfred J. Krause)<quote>

On Thu, Apr 5, 2012 at 9:05 AM, Florian Reisinger wrote:

- Zitierten Text ausblenden -
> Hallo!
>
> IMHO reicht zur Reproduktion eine Tabelle, die sich auf mehrere Seiten
> erstreckt, wie:
>
> http://www.box.com/s/1fd4331d0607c49bcb7c
>
> Ziel: Alle Reihen, außer die 1. zu markieren:
>
> Oben nach unten ( Mit der 2. Zeile beginnend ): Schlägt fehl (jedenfalls so
> wie ich es mache)
> Unten nach oben: ( Mit der letzten Zeile beginnend): Funktioniert
"Oben nach unten" funktioniert, wenn du z. B. den Cursor in A2 (vor
'aeger') setzt und dann mit gedrückter linker Maustaste nach unten bis
B39 markierst."

Bei der Methode (deiner?), vom linken Seitenrand von oben nach unten
zu markieren (Mauszeiger als Pfeil nach rechts; 'select table row'),
bleibt die Markierung am unteren Fensterrand hängen. Von unten nach
oben kein Problem.

[LibreOffice 3.5.2.2 · UI en-US · WinXP 32b]

Z. B. bei LibreOffice 3.3.4 oder OOo 3.2.1 ist das nicht anders.  

Schönen Tag
Manfred
</quote>
The problem is: You can't mark a table from the top down, using "select table row"...
Comment 3 Rainer Bielefeld Retired 2012-04-05 05:09:26 UTC
Now I see. [Reproducible] with reporter's sample and with "LibreOffice 3.5.2.2 German UI/Locale [Build-ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f] on German WIN7 Home Premium (64bit). Can be reproduced with every document containing table exceeding screen. Has already been reported as "Bug 35829 - EDITING table: can not select rows by mouse"

*** This bug has been marked as a duplicate of bug 35829 ***