Download it now!
Bug 48333 - Path changed to <home> (as defined in the users options) with File > Save As, File>Template>Edit, ...
Summary: Path changed to <home> (as defined in the users options) with File > Save As,...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other Linux (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard: (target:3.6.0)
Keywords: regression
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-04-05 05:23 UTC by Cor Nouws
Modified: 2012-08-03 04:23 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2012-04-05 05:23:16 UTC
- open existing file somewhere in path <home>/xx/yy
- File > Save as
- change name/extenions
- OK
- try to find file in path <home>/xx/yy
  > it's not there, it is in path <home>
Comment 1 Cor Nouws 2012-04-05 05:25:19 UTC
found in
LOdev 36daily120404 3.6.0alpha0+ 
Build ID: 290654c-042f74a-6299bf6-879ce36-186d9e

( possibly related to the cool improvements in the file save dialogue ? :
http://cgit.freedesktop.org/libreoffice/core/commit/?id=5e301969bf1c8818b5c737757363c31584823485  )
Comment 2 Cor Nouws 2012-04-05 15:19:18 UTC
The problem also shows when I choose File>Template>Edit ..
Comment 3 Cor Nouws 2012-04-06 00:11:17 UTC
.. and with File > Export as PDF
annoying :-(
Comment 4 Cor Nouws 2012-04-06 02:11:57 UTC
( could it be that LibreOffice uses hidden files in the /TMP folder for these actions ? If so:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=dd2fe95cce75f1157bd1c75d286a0047b2e4175e )
Comment 5 Cor Nouws 2012-04-15 05:35:05 UTC
 Insert > Graphics from file
now defaults to <home> too
(previously, the value from Options > General > Paths was used there
Comment 6 Björn Michaelsen 2012-04-19 05:23:24 UTC
Cant reproduce this in the latest Ubuntu 3.5 release, which includes the patch. Cor, could you recheck the latest upstream Linux 3.5 release, just to be sure?

If it is indeed not on 3.5 (and I hope so), than we would need bibisect to hunt this down.
Comment 7 Cor Nouws 2012-04-19 06:26:19 UTC
(In reply to comment #6)
> Cant reproduce this in the latest Ubuntu 3.5 release, which includes the patch.

You mean which of the two patches I mentioned ?

> Cor, could you recheck the latest upstream Linux 3.5 release, just to be sure?

Hmm, where is that one? I have all version from LibreOffice.
And run an older Ubuntu (11:04) with Libre 3.3.4 IIRC

> If it is indeed not on 3.5 (and I hope so), than we would need bibisect to hunt
> this down.

It definitely orrucs first in one of the daily/master builds I have here.

The last build I have where it was OK is:
LOdev 36daily120326 3.6.0alpha0+ 
Build ID: a04fee7-4d74905-6299bf6-879ce36-4c023a

And the first one that I have with the error is the one I already reported:
LOdev 36daily120404 3.6.0alpha0+ 
Build ID: 290654c-042f74a-6299bf6-879ce36-186d9e
Comment 8 Björn Michaelsen 2012-04-19 07:49:23 UTC
@Cor, I was talking about this change:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=dd2fe95cce75f1157bd1c75d286a0047b2e4175e

It is on -3-5, but not on -3-5-3 so you wont see it on the 3.5.3 rc. If you are on Ubuntu 11.10, this is PPA:

https://launchpad.net/~libreoffice/+archive/ppa

should give you 1:3.5.2-2ubuntu1~oneiric1 which includes that patch. If you would recheck with that version that would be lovely.

Since the behaviour you are describing hints at the lp#905355 patch, it might be that Martin Richards patch causes it to break in interesting ways?
Comment 9 Cor Nouws 2012-04-19 13:22:38 UTC
@Bjoern:
(In reply to comment #8)
> It is on -3-5, but not on -3-5-3 so you wont see it on the 3.5.3 rc. If you are
> on Ubuntu 11.10, this is PPA:
> 
> https://launchpad.net/~libreoffice/+archive/ppa

I'm on 11:04 ...
So I got stuck, can't add this version. And I find this on the net:
  https://launchpad.net/~ricotz/+archive/ppa/+build/3397470
but apparently not a tar ?
Comment 10 Cor Nouws 2012-04-19 15:00:14 UTC
Just found out, that the bug is related to the use of the native LibreOffice dialog (Tools > Options > LibreOffice General )
With the systems file dialog, it works fine.
Comment 11 Björn Michaelsen 2012-04-19 15:12:36 UTC
Cannot reproduce this on the 1:ubuntu-3.5.2-2ubuntu1 version on precise which includes the commit dd2fe95cce75f1157bd1c75d286a0047b2e4175e as a patch. _Can_ reproduce on master with LibreOffices own dialogs. So likely dd2fe95cce75f1157bd1c75d286a0047b2e4175e alone is fine, but 5e301969bf1c8818b5c737757363c31584823485 on top of it broke it.

@Cedric: Care to have a look?
Comment 12 Roman Eisele 2012-04-19 22:12:55 UTC
Just FYI:
I could not reproduce this problem on MacOS X 10.6.8 with LOmaster 3.6.0alpha0+, Build ID: 55823d3 (installation file: master~2012-04-14_05.23.05_LibO-Dev_3.6.0alpha0_MacOS_x86_install_en-US.dmg), even when using the native LibreOffice file dialogs (Tools > Options > LibreOffice General).
Comment 13 Rainer Bielefeld Retired 2012-04-19 23:17:52 UTC
This one seems to be more or less concerning the same problem  (or at least an other aspect) of "Bug 48494 - CONFIGURATION: Path settings not persistent"

I can confirm reported problem with latest WIN Master Builds.

@Bjoern: This is a "Master" bug related to the completely new file dialog, that can't be checked with 3.5
Comment 14 Cor Nouws 2012-05-01 05:24:23 UTC
see this commit 
  https://bugs.freedesktop.org/show_bug.cgi?id=43895#c12
Comment 15 Cor Nouws 2012-05-01 05:24:43 UTC
verified in version 3.6.0alpha0+ Build ID: 87897ea
Comment 16 Stephan Bergmann 2012-05-02 00:50:21 UTC
(In reply to comment #14)
> see this commit 
>   https://bugs.freedesktop.org/show_bug.cgi?id=43895#c12

Looks more like what fixed it is <http://cgit.freedesktop.org/libreoffice/core/commit/?id=449440706c6db8f10d37321ed1280d986d07b9f3> "NOINITIALSELECTION important for Save As" rather than <http://cgit.freedesktop.org/libreoffice/core/commit/?id=2d0ff6aa5d6951aaa00e2d6cf3878788b025983e> "Related fdo#43895: Fixed shortcommings of FileDialogHelper_Impl::verifyPath" (i.e., not relevant for the 3.5 branch).
Comment 17 Cor Nouws 2012-05-02 00:59:11 UTC
(In reply to comment #16)
> Looks more like what fixed it is

Ah well, if you say so :-)
Comment 18 Cédric Bosdonnat 2012-05-04 03:24:05 UTC
(In reply to comment #16)
> (In reply to comment #14)
> > see this commit 
> >   https://bugs.freedesktop.org/show_bug.cgi?id=43895#c12
> 
> Looks more like what fixed it is
> <http://cgit.freedesktop.org/libreoffice/core/commit/?id=449440706c6db8f10d37321ed1280d986d07b9f3>
> "NOINITIALSELECTION important for Save As" rather than
> <http://cgit.freedesktop.org/libreoffice/core/commit/?id=2d0ff6aa5d6951aaa00e2d6cf3878788b025983e>
> "Related fdo#43895: Fixed shortcommings of FileDialogHelper_Impl::verifyPath"
> (i.e., not relevant for the 3.5 branch).

Thanks Stephan for fixing this one.