Download it now!
Bug 48366 - FILEOPEN for particular .xlsx impossible, "General Error"
Summary: FILEOPEN for particular .xlsx impossible, "General Error"
Status: RESOLVED DUPLICATE of bug 54609
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.6.2 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-05 23:24 UTC by Håkan Wallenthin
Modified: 2013-12-04 21:17 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
I'ts a downloaded file from my bank with transactions (10.67 KB, application/vnd.openxmlformats)
2012-04-05 23:24 UTC, Håkan Wallenthin
Details
The Journal is generated on the corporate website. (10.81 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2012-07-18 11:54 UTC, arcfi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Håkan Wallenthin 2012-04-05 23:24:56 UTC
Created attachment 59573 [details]
I'ts a downloaded file from my bank with transactions

When I try to open a xlsx-document I get a message: 

   General Error
General input/output error

There's nothing else to choose than OK. When I select that LO isn't opened.


This is a problem for the latest 3.5 releases. I can open the document with LO 3.4.5

I attach the document I try to open
Comment 1 arcfi 2012-07-18 11:53:43 UTC
Same problem.
LibreOffice 3.5.5.3 Windows x86
LibreOffice 3.5.4.2 Linux x86_64
Comment 2 arcfi 2012-07-18 11:54:37 UTC
Created attachment 64348 [details]
The Journal is generated on the corporate website.
Comment 3 Håkan Wallenthin 2012-09-04 18:02:18 UTC
I've tested to open a xlsx-file with Calc-version 3.6.1.2 and I get the same result as earlier. To me this bug isn't solved.
Comment 4 Rainer Bielefeld Retired 2012-09-06 17:35:54 UTC
[Reproducible] with Server Installation of "LibreOffice 3.5.1.2 German UI/Locale [Build-ID: dc9775d-05ecbee-0851ad3-1586698-727bf66] on German WIN7 Home Premium (64bit). Attempt to open ends with message "General Error. General input/output error.

Already [Reproducible] with "LibreOffice 3.5.1.2 German UI/Locale [Build-ID: dc9775d-05ecbee-0851ad3-1586698-727bf66] on German WIN7 Home Premium (64bit) 

Worked fine with 3.4.5, so Regression

Still [Reproducible] with parallel installation of Master "LOdev  3.7.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: 6cad15d]"  {tinderbox: @6, pull time 2012-09-03 23:08:07} on German WIN7 Home Premium (64bit)  (installation without Base)

@Spreadsheet Team
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf.    (and remove others in team from CC)
Comment 5 Rainer Bielefeld Retired 2012-09-07 18:07:49 UTC
Related to "Bug 54609 - CRASH when FILEOPEN particular .xlsx"? That one uses a very similar sample document.
Comment 6 Kohei Yoshida 2012-09-20 15:31:44 UTC
(In reply to comment #5)
> Related to "Bug 54609 - CRASH when FILEOPEN particular .xlsx"? That one uses a
> very similar sample document.

Yes. In fact, the fix for Bug 54609 also fixes this bug too.
Comment 7 Kohei Yoshida 2012-09-20 18:21:25 UTC
I'll close this as a duplicate.

*** This bug has been marked as a duplicate of bug 54609 ***