Bug Hunting Session
Bug 48394 - PRINTING Landscape documents are not rotated to fit a portrait page
Summary: PRINTING Landscape documents are not rotated to fit a portrait page
Status: RESOLVED DUPLICATE of bug 44664
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-06 11:54 UTC by tjbp
Modified: 2012-06-15 02:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tjbp 2012-04-06 11:54:56 UTC
When printed, landscape documents are not rotated to fit the page. The margin sizing of the document is retained, and the text disappears of the side of the page and is clipped.

Landscape is also selected in the printer settings automatically - if this is switched to Portrait, the document is printed as it should (centred vertically and horizontally, and clipped).

Steps to reproduce:

- Fill a page with text.
- Click Format > Page, then the Page tab.
- Configure a Landscape Orientation and click OK.
- Print the document.
Comment 1 Maciej Pilichowski 2012-05-31 03:17:05 UTC
Confirmed in 3.5.3 and 3.5.4.

Known workaround:
* export document to PDF
* open exported PDF (in evince, okular, kpdf and so on)
* print it
Comment 2 Rainer Bielefeld Retired 2012-05-31 03:50:20 UTC
I never saw orientation problems. NOT reproducible with "LibreOffice 3.5.4.2 (RC2) German UI/Locale [Build-ID: 165a79a-7059095-e13bb37-fef39a4-9503d18] on German WIN7 Home Premium (64bit) and proceeding as per original report.

1. open new document (a4 portrait)
2. 3 paragraphs Lorem Ipsum
3. Change 'Format -> Page -> Page -> Orientation' to landscape
   > works perfect, now text lines are parallel to long paper sheet margin
4. Print with Samsung CLX-3185 (what always prints contents 
   landscape/portrait for me as expected):
    > works perfect, text lines are parallel to long paper sheet margin as
      on screen

Linux / printer driver related? The report is much too rare to find out the reasons. I will do additional tests with Linux when additional information will be available.

The way reporter works is without logic. First writes texts, then changes orientation of "paper sheet"? But that does not matter for me.

@tjbp:
Please contribute additional information due to <http://wiki.documentfoundation.org/BugReport>, (analogous Bug 50155#C1):
Your printers, drivers, printer settings, view in print preview, view in page preview, ... Linux Version, all the rest, ...
Comment 3 Maciej Pilichowski 2012-05-31 04:00:53 UTC
> Linux / printer driver related?

Nope. See workaround.

> I will do additional tests with Linux when additional information will
> be available.

For starter, just do it once, just to check if with initial setup and basic steps you can reproduce it. The report is about Linux, and you try to find counter-confirmation reproducing it on Windows -- it makes only sense if you see the problem, but since you don't see it, the conclusion is, you are not using right setup.

> The way reporter works is without logic. First writes texts, then changes
> orientation of "paper sheet"? 

Plenty of people do it this way. And plenty don't.

The details in my case are: print via file/print, print via quick-print in toolbar, opensuse 12.1 32-bit, XFCE 4, printer Lexmark 120, driver Lexmark Optra E+ Foomatic/ljet4.
Comment 4 sasha.libreoffice 2012-06-15 02:39:43 UTC

*** This bug has been marked as a duplicate of bug 44664 ***