Bug Hunting Session
Bug 48414 - Can't print to a CUPS printer that requires authentication
Summary: Can't print to a CUPS printer that requires authentication
Status: RESOLVED DUPLICATE of bug 53029
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-07 05:50 UTC by Sam Morris
Modified: 2013-06-20 11:55 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sam Morris 2012-04-07 05:50:25 UTC
When I print from a program such as Evince, after I press print, but before the job is sent to the printer,  I'm prompted for a username/password. When I print from Libreoffice, the print job just sits in the queue forever. The following goes to CUPS' error_log:

E [07/Apr/2012:13:44:21 +0100] [Job 108] Tree connect failed (NT_STATUS_ACCESS_DENIED)

I guess CUPS is sending the job on to the Windows system that the printer is attached to without attempting to authenticate.

Here's the contents of CUPS' printers.conf:

<DefaultPrinter laser>
 UUID urn:uuid:f95f96b2-3897-38f7-48b5-146eaf08476a
 AuthInfoRequired username,password
 Info laser
 MakeModel Samsung CLP-300 Foomatic/foo2qpdl (recommended)
 DeviceURI smb://tycho/laser
 State Idle
 StateTime 1333802662
 Type 12619804
 Accepting Yes
 Shared Yes
 JobSheets none none
 QuotaPeriod 0
 PageLimit 0
 KLimit 0
 OpPolicy authenticated
 ErrorPolicy stop-printer
</Printer>
Comment 1 Dennis Schridde 2013-06-20 10:55:34 UTC
This might have a duplicate in bug #53029.
Comment 2 Thijs Kinkhorst 2013-06-20 11:55:45 UTC

*** This bug has been marked as a duplicate of bug 53029 ***