Bug 48443 - Particular Subtracted shapes not compatible LibO 3.4 - 3.5
Summary: Particular Subtracted shapes not compatible LibO 3.4 - 3.5
Status: RESOLVED DUPLICATE of bug 47406
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.0 RC2
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-04-08 13:36 UTC by Ferry Toth
Modified: 2012-04-12 10:33 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Exalon Delft logo (12.27 KB, application/vnd.oasis.opendocument.graphics)
2012-04-08 13:36 UTC, Ferry Toth
Details
Exalon Delft logo as shown in pre 3.5 LibreOffice (6.19 KB, application/pdf)
2012-04-08 13:37 UTC, Ferry Toth
Details
Distorted in 3.5 and at least 3.5.1 (6.19 KB, application/pdf)
2012-04-08 13:38 UTC, Ferry Toth
Details
Displays well in 3.4.4, distorted in 3.5.0, 3.5.1, 3.5.2 (9.26 KB, application/vnd.oasis.opendocument.graphics)
2012-04-11 01:13 UTC, Ferry Toth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ferry Toth 2012-04-08 13:36:28 UTC
Created attachment 59654 [details]
Exalon Delft logo

Our company logo has been for a long time as in the attached drawing (odg).

In pre-3.5 if has always shown as in the ExalonDelftLogo 3.4.4.pdf.

Starting from 3.5 the original element that have been used to create the logo are displaced as shown in ExalonDelftLogo 3.5.pdf.

The same problems happen in 3.5.1.

Also, the problems happen in our Writer templates where we have this odg embedded (as an object).

Strange - are we the only ones suffering from this?

Ferry
Comment 1 Ferry Toth 2012-04-08 13:37:21 UTC
Created attachment 59655 [details]
Exalon Delft logo as shown in pre 3.5 LibreOffice
Comment 2 Ferry Toth 2012-04-08 13:38:12 UTC
Created attachment 59656 [details]
Distorted in 3.5 and at least 3.5.1
Comment 3 Ferry Toth 2012-04-09 12:52:35 UTC
Ha, just found this bug to be resolved in LO 3.5.2 (verified with the Windows version).

Ferry
Comment 4 Ferry Toth 2012-04-10 03:24:33 UTC
But not resolved entirely:

Opening Exalon Delft logo with 3.5.2 and saving it again, then opening in 3.4.4 shows the same type of distortion.

I don't think this bug can be closed yet.

Ferry
Comment 5 Rainer Bielefeld Retired 2012-04-10 10:41:45 UTC
Modify Version due to Comments.

Reported problem not reproducible with "LibreOffice 3.5.2.2 German UI/Locale [Build-ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f] on German WIN7 Home Premium (64bit). But I can confirm effect from Comment 4

@Ferry Toth
Your OS?
Comment 6 Ferry Toth 2012-04-10 11:06:21 UTC
OK, so this is the status:

The 'particular shapes' have been created a draw object with OO 3.2.1 and embedded in a writer document.
The have now been 'saved as a copy' draw document by LO 3.4.4.
Opening this using 3.5.0, 3.5.1 and 3.5.2 shows a broken drawing.
Opening with 3.4.4 shows no problems.
Saving again (without modifications) by LO 3.4.4 (this is the version I attached above).
With 3.4.4 no problem.
With 3.5.0, 3.5.1 broken.
With 3.5.2 displays OK.
Then saving with 3.5.2, opens in 3.5.2 without problem.
In 3.4.4 and 3.4.6 broken.

Versions used:
3.4.4 Ubuntu Oneric
3.4.6 W7 x64 native
3.5.0, 3.5.1, 3.5.2 Windows (native W7 x64, virtual box W7 i32 and x64)
Comment 7 Ferry Toth 2012-04-11 01:09:34 UTC
To help reproduce the original problem I attached the freshly extracted embedded object ExalonLogo_embedded.odg.

This one displays well in 3.4.4 but not in 3.5.2.

Ferry
Comment 8 Ferry Toth 2012-04-11 01:13:51 UTC
Created attachment 59790 [details]
Displays well in 3.4.4, distorted in 3.5.0, 3.5.1, 3.5.2

Extracted (save copy as ..) from a writer document using 3.4.4, originally created using 3.2.1 (?), but not opened / re-saved in 3.4.4.
Comment 9 Rainer Bielefeld Retired 2012-04-11 01:52:03 UTC
Yes, "Displays well in 3.4.4, distorted in 3.5.0, 3.5.1, 3.5.2"  perfectly show the problem, what is not fixed in parallel  installation of  Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 4495824-6299bf6-ec8645]" (tinderbox: Win-x86@6-fast pull time 2012-04-08 00:03:52)

Alreadx a problem with 3.5.0RC2,  still worked fine with3.5.0 Beta0

@Thorsten:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug
Comment 10 Ferry Toth 2012-04-11 08:18:52 UTC
Any chance this can be fixed in LO 3.5.3 (i.e. in a Ubuntu service release)?

Or do we need to wait for the fix to land in 3.6?

(I don't about other organizations, but in ours windows user are on OO 3.2.1 and Kubuntu users on LO 3.4.4. It would be very nice if we could all to use the same LO while still being able to open our old documents).

Ferry
Comment 11 Thorsten Behrens (CIB) 2012-04-12 05:06:50 UTC
This is a dupe, and should therefore be fixed in 3.5.2.

3.4.4 is broken, and can't retroactively be fixed. I don't know how relevant this is in practice, potentially one could add a hidden config item "export broken svg", or tie it to ODF1.0/1.1 export (though I'd hate that - it is indeed written wrongly).

*** This bug has been marked as a duplicate of bug 47406 ***
Comment 12 Ferry Toth 2012-04-12 10:33:31 UTC
I don't know what you mean by '3.4.4 is broken'?

We are creating and editing documents with OO 3.2.1 and LO 3.4.4 intermixed without having this problem. Problems start with 3.5.0 and occur also in 3.5.2.

So it is either not fixed in 3.5.2 or has existed from at least from 3.2.1 until 3.4.4.

Considering the amount of documents created in that period of time, I don't think it is reasonable to say 'it is fixed in 3.5.2'.

Unless you have a workaround to work on 3.5.2 documents with OO 3.2.1 and LO3.4.4?

Something more elegant then: export it to MS doc.

Ferry