Download it now!
Bug 48461 - FORMATTING - Proposal for improving 'fill characters' (bleeding, leading tabs)
Summary: FORMATTING - Proposal for improving 'fill characters' (bleeding, leading tabs)
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-09 03:28 UTC by Bob Harvey
Modified: 2016-01-18 18:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
TOC dialog with styles tab (47.29 KB, image/png)
2016-01-18 18:14 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Harvey 2012-04-09 03:28:33 UTC
I made the following two proposals for OOo:
https://issues.apache.org/ooo/show_bug.cgi?id=28510
https://issues.apache.org/ooo/show_bug.cgi?id=28511

The first was to allow the fill characters to be aligned vertically with each other down the page in an index table, the other to allow them to be greyed (or transparented).

I would like to see LibreOffice doing something about this, particularly the first one.  In printed books fill characters are arranged in a neat matrix, line below line, not spaced off the end of the index word.
Comment 1 Bob Harvey 2012-08-12 07:47:32 UTC
Any thoughts on this?
Comment 2 Bob Harvey 2012-10-25 10:43:21 UTC
Bump - still unconfirmed after 6 months
Comment 3 Joel Madero 2013-11-18 22:15:58 UTC
Unfortunately part of the reason this has been in UNCONFIRMED for so long is because it requires us to dig through comments on someone else's bug tracker. We require clear and concise information on our bug tracker - saying "click this link and see" is not sufficient. Please provide the information here and if necessary say "see comment #n" on PROVIDE LINK) - vs. just "go browse this extensive bug report on AOO's framework.


Marking as NEEDINFO. Once clear info is provided here, including pointers to what comments we should look at on the link you provided, mark as UNCONFIRMED and we'll see if we can at least get it to NEW status.

Thanks for your understanding
Comment 4 Bob Harvey 2013-11-19 05:09:49 UTC
OK, fair enough.

1.  Bleeding (or leading) tabs fill in between TOC text on the left and the page numbers on the right.   In LO this is done with a character specified as a fill character, but those are left justified the same way as the text.  That means that, with a proportional font for the text, they don't line up down the page: the dots on one row might fall in between the dots on the row above, creating an unpleasant mash.   My proposal would have:
- A minimum white space between the text and the bleed
- A minimum white space between the bleed and the page number
- the fill characters would be right-justified and right-aligned so that they form attractive vertical columns on the page.

The present system of tabs can be used to set the final white space between the right hand end of the bleed and the page number, and a number of similar tabs (according to how variable the text lengths are), the point where the bleed starts on the left.


2.  The text and the index number can be made to stand out better if the fill characters are greyed relative to the text and the index number.  

It will be easier to follow the bleed across the page if the level of greying were to be different for successive lines.  This is similar to the green and white stripes on old-fashioned fanfold "music" printouts.  For example, you might provide the option to have four levels of greying (or transparency) for the bleed fill characters and apply them sequentially, allowing the user to select schemes like:
80%
60%
40%
20%
or alternatively
75%
25%
75%
25%
or even
90%
0%
90%
0%
to produce alternate rulings and blanks.

Some finessing might be applied according to heading levels, if possible: the sequence of 4 might want to be reset for new chapters or new heading levels 1, or the greying/transparency might be set by heading level instead of (or as well as?) the sequential idea.  

In my mind the actual level of greying would be the multiplicative product of the sequential and the heading level settings, such that setting either one to all 100% would select the other technique instead, or they could be mixed by someone creative.
Comment 5 Joel Madero 2013-11-19 06:08:09 UTC
Thanks Bob - just gets complicated when we are jumping around bug trackers with a ton of comments. 

Marking as UNCONFIRMED
Comment 6 Bob Harvey 2015-09-16 16:04:16 UTC
Aby further ideas on this?
Comment 7 Joel Madero 2015-09-16 18:09:06 UTC
Should get ux input - in all honesty, it could take a long time to implement this as volunteers would have to find it interesting (and prioritize it over the other several thousand bugs).
Comment 8 Bob Harvey 2016-01-18 07:44:38 UTC
Still keen.
It occurs that  right-to-left typologies may need the logic inverting.  I know nowt about how RTL systems handle TOC however.
Comment 9 Joel Madero 2016-01-18 07:55:57 UTC
Again, please don't bump enhancements. Thanks
Comment 10 Heiko Tietze 2016-01-18 08:31:00 UTC
The TOC dialog provides option to style each level individually. And this paragraph style has all options about fill characters and transparency.
If you want to middle align the TOC vertically you could use a table with a single cell. In case of a variable distance of lines so that the content is spread over the whole page I'm afraid you have to play with the line spacing. Perhaps someone else has an idea how to achieve that automatically.
I'd say you can have what you want with the existing functionality - WORKSFORME. But maybe I miss something. In this case it would be helpful to add an example how it should look eventually.
Comment 11 Bob Harvey 2016-01-18 17:12:22 UTC
@ Heiko Tietze 

well, the fill character is not right justified, and I can't find any way to make white space between the index text and the run of fill characters.  The 'transparency' setting has to be done by hand, it can't be automatic.  I rather thought I had suggested what I thought it should look like, but hey.

But mine was an enhancement suggestion made originally in 2011.  If no-one else has suggested it and no-one wants to take it on, then I guess it can be rejected.  It doesn't seem like a works for me to me.
Comment 12 Heiko Tietze 2016-01-18 18:14:18 UTC
Created attachment 122062 [details]
TOC dialog with styles tab

You can assign a style to the index levels, as shown in this screenshot. This paragraph style has the option "tabs" where type and fill char can be modified as well as transparency.
Couldn't you try to simulate with direct formatting or image processing how it should look like, if this doesn't help?