Bug 48503 - Help on 'autocomplete' crashes.
Summary: Help on 'autocomplete' crashes.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2012-04-10 06:32 UTC by Joop Lanting
Modified: 2016-10-19 23:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (68.44 KB, image/png)
2012-04-10 06:32 UTC, Joop Lanting
Details
pop-up (53.25 KB, image/png)
2012-04-15 00:49 UTC, Joop Lanting
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joop Lanting 2012-04-10 06:32:09 UTC
Created attachment 59726 [details]
Screenshot

See attachment: Find info on 'autocomplete' crashes LibreOffice Writer 3.5.2.

;JOOP!
Comment 1 Rainer Bielefeld Retired 2012-04-10 10:07:23 UTC
NOT reproducible with "LibreOffice 3.5.2.2 English UI/Locale [Build-ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f] on German WIN7 Home Premium (64bit)
Comment 2 Joop Lanting 2012-04-11 02:03:57 UTC
Reproduced on Home/Premium Windows 7 laptop with internet disconnected:

no crash but "LibreOffice has stopped"

Same version (3.5.2.2 / GB)

;JOOP!
Comment 3 Joop Lanting 2012-04-11 02:42:53 UTC
Even reproduced on XP laptop with 3.5.2.2

Now I'm going to suspect JAVA: I run JAVA 7u3 everywhere .......
LibreOffice 'sees' JAVA 1.7.0_03 but the help says "it's defective".
I verified all JAVA installations and they're fine.
I presume 3.5.2.2 is not entirely prepared for JAVA 7 ......

;JOOP!
Comment 4 Julien Nabet 2012-04-14 13:20:36 UTC
Could you try with a brand new LO profile ?
Comment 5 Joop Lanting 2012-04-15 00:21:46 UTC
If found this file: javasettings_Windows_x86.xml in each account.
It contains:

<location>file:///C:/Program%20Files/Java/jdk1.6.0_30/jre</location>
<version>1.6.0_30</version>

I wonder why those lines were never updated when I updated LO (twice)
AFTER I un-installed JAVA 1.6 and installed JAVA 1.7

I'd rather change those lines by hand than to throw away all my settings.
OK?

;JOOP!
Comment 6 Julien Nabet 2012-04-15 00:26:36 UTC
First thank you for your feedback.
Make a backup of your LO profile and yes you can try. Keep us informed, it could be an interesting bug to solve.
Comment 7 Joop Lanting 2012-04-15 00:46:55 UTC
I edited the file (on WindowsXP):

c:\Documents and Settings\joop\Application Data\LibreOffice\3\user\config\javasettings_Windows_x86.xml

replacing only those 2 directory names: 1.6.0_30 into jdk1.7.0_03

I tried the Help-Find and: see attached crash page.

(I did not SEND to MS)

;JOOP!
Comment 8 Joop Lanting 2012-04-15 00:49:22 UTC
Created attachment 60004 [details]
pop-up

Almost the same as before.
Comment 9 Julien Nabet 2012-04-15 01:34:56 UTC
For the test, could you :
- move the directory of your LO profile so you have a backup + it will force LO to recreate a brand new profile when you start it again
- create a special backup of javasettings_Windows_x86.xml (javasettings_Windows_x86.xml.backup)
- launch LO (it creates the new LO profile) and test if it's ok
- if it's ok, replace javasettings_Windows_x86.xml of your backup profile with the javasettings_Windows_x86.xml of the brand new LO profile
then remove the brand new LO profile and move back your backup LO profile to its original location

(hope it's clear :-) )
Comment 10 Joop Lanting 2012-04-15 03:14:36 UTC
It was clear, BUT ......................

I moved the whole directory tree
 c:\Documents and Settings\joop\Application Data\LibreOffice

to a safe place, then re-run LO Writer.
- lost all settings and customisations as expected,
- did create a brand new tree,
- did NOT create a new "javasettings_Windows_x86.xml"

Moreover: when I hit F1 or Help, there's no help any more but my browser is run with:

http://help.libreoffice.org/swriter/SW_HID_EDIT_WIN?Language=en-US&System=WIN&Version=3.5#bm_id3147244

So, ................. ????

;JOOP!
Comment 11 Julien Nabet 2012-04-15 09:06:55 UTC
Try to uninstall the jre you don't use and try again with a brand new LO profile.
You should come sometimes on irc #libreoffice channel (try to use Joop as nickname), mine is julien2412
Comment 12 Joop Lanting 2012-04-15 11:42:37 UTC
Sorry to disappoint you but:
- I un-installed that unused JRE from the start,
- I'm too old for other social media than this.

;JOOP!
Comment 13 Björn Michaelsen 2012-08-31 10:09:56 UTC
this seems to be related to (and possibly a dupe of): https://bugs.freedesktop.org/show_bug.cgi?id=38913
Comment 14 retired 2013-03-23 16:30:48 UTC
Since the bug Björn mentions has been resolved by now, Joop, could you please try reproducing this problem with LO 4?
Comment 15 Joop Lanting 2013-03-25 08:17:38 UTC
Because of several early version 4 bugs I delayed upgrading and remained in 3.8
for some time.
You triggered me into upgrading on all our systems (3):

1) WindowsXP, JAVA 7u17 (only), LibO 4.0.1.2 GB :: OK
more to come.
;JOOP!
Comment 16 Joop Lanting 2013-03-25 12:59:17 UTC
2) Mountain Lion 10.8.3 on MacBook Pro Retina, JAVA 1.6.0_43 (APPLE),
LibO 4.0.1.2 GB :: OK

Failed to tell LibO to run from the also installed JAVA 7u17:
it refuses to accept the path to that JRE (while ECLIPSE does!);
then again, for the time being it might be better, the GUI and fonts are displayed sharply, so may be this is Retina supported (?!?).

more to come.
;JOOP!
Comment 17 Joop Lanting 2013-03-26 07:16:13 UTC
And finally:
3) Windows7, JAVA 7u17 (64 bits and 32 bits JRE), LibO 4.0.1.2 GB :: OK

Will I uninstall the 32 bits JRE to force all on the 64 bits JRE?

;JOOP!
Comment 18 Julien Nabet 2013-03-26 08:24:43 UTC
Joop: since LO is 32 bits only for Windows, I would say you should only keep 32bits Java but it's just a guess.
Comment 19 Joop Lanting 2013-03-26 09:27:26 UTC
As I develop in JAVA7 with 64 bits as a target I'll keep everything as it is now.
OK, solved?

;JOOP!
Comment 20 Julien Nabet 2013-03-26 09:31:49 UTC
If everything works for you, you can put it SOLVED.
I didn't think that Java 64 would work with LO 32 but I'm not at all an expert and if you say it's ok... :-)
Comment 21 Joop Lanting 2013-03-26 10:03:57 UTC
To be honest, it seems like ages that I knew what exactly was going on in 'my' computer(s).
Nowadays I'm satisfied if it does the job.
Thanks for all attention.

;JOOP!
Comment 22 Julien Nabet 2013-03-26 10:05:37 UTC
Since, there's no specific fix, I put WFM.