Bug 48516 - FILEOPEN: CSV: "Maximum number of rows" message used when there are too many columns
Summary: FILEOPEN: CSV: "Maximum number of rows" message used when there are too many ...
Status: RESOLVED DUPLICATE of bug 43911
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Eike Rathke
QA Contact:
URL:
Whiteboard: target:3.6.0
Keywords:
Depends on:
Blocks: 39868
  Show dependency treegraph
 
Reported: 2012-04-10 11:04 UTC by Eike Rathke
Modified: 2012-04-12 16:48 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eike Rathke 2012-04-10 11:04:44 UTC
Opening a CSV file containing more columns than supported displays the "maximum numbers of rows exceeded" message, it should say columns instead.

Related:
https://issues.apache.org/ooo/show_bug.cgi?id=75199
Test case file attached there (2nd attachment) as
https://issues.apache.org/ooo/attachment.cgi?id=68471
Comment 1 Markus Mohrhard 2012-04-10 13:04:25 UTC

*** This bug has been marked as a duplicate of bug 43911 ***
Comment 2 Not Assigned 2012-04-10 14:53:22 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=684cf5cca6ea6c8fc2743f1622f624f668db9e84

resolved fdo#48516 use "max columns exceeded" message if appropriate
Comment 3 Not Assigned 2012-04-12 16:48:10 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9f77876a96911a7138aa2081077a03abd34a9cf4

two additional places to raise data truncated error for fdo#48516