Download it now!
Bug 48571 - : Allow A:A format to include an entire column and 1:1 format to include an entire row
Summary: : Allow A:A format to include an entire column and 1:1 format to include an e...
Status: CLOSED DUPLICATE of bug 44419
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: All All
: highest major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 71560 91819 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-11 15:01 UTC by 7qia0tp02
Modified: 2015-06-16 16:25 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 7qia0tp02 2012-04-11 15:01:00 UTC
Problem description: 

As described [here](http://user.services.openoffice.org/en/forum/viewtopic.php?f=9&t=9527), other spreadsheets allow the syntax "A:A", which means "all elements in column A".  

LibreOffice doesn't support this, and I would like it to be added.  The closest workaround is "A1:A65536".  The problem with A1:A65536 is that the number will change if you delete rows, if you try to enter it for a graph, the range will be shrunk to fit your data to something like "A1:A35", and not expand as you add more data, etc.

Platform (if different from the browser): 
Windows 7 64-bit
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 1 Sören 2012-08-14 15:09:09 UTC
Still doesn't work in neither

LibreOffice 3.5.5.3 
Build ID: 7122e39-92ed229-498d286-15e43b4-d70da21
on Windows 7 Home (64 bit)

nor
LibreOffice 3.5.4.2 
Build ID: 350m1(Build:2)
on Ubuntu 12.04 (64 bit)
Comment 2 V.K. 2012-11-11 09:42:28 UTC
It is very convenient feature in Excel. So, I think it must be implemented in Calc. As well as possibility to insert such reference in formula by clicking the column or row header. 

----
LO 3.6.3.2
Win 7 SP1
Comment 3 m.a.riosv 2013-11-13 09:15:48 UTC
*** Bug 71560 has been marked as a duplicate of this bug. ***
Comment 4 bugquestcontri 2014-12-30 11:50:37 UTC
This feature would reduce a lot of questions in AskLibO. Today was another one:
http://ask.libreoffice.org/en/question/44174/how-to-select-entire-column-while-using-vlookup-function-in-calc/

Also when using not the entire column, and using the formula generator (click the fx icon), Calc should automatically make the references for the corner cell to absolute references. 
There is also something more in the above link to AskLibO
Comment 5 Gitsy 2014-12-30 12:51:48 UTC
As Calc doesn't support the "entire column addressing" (or "entire row") which results very inconvenience while opening spreadsheets created by other programs

for example:  In a sheet created in google doc the formula =VLOOKUP(B8,Sheet1!B:D,3,0) perfectly works. But in Calc the formula returns error.
Comment 6 Wolfgang Jäger 2015-01-11 13:21:27 UTC
(In reply to bugquestcontri from comment #4)
> This feature would reduce a lot of questions in AskLibO. Today was another
> one:
> http://ask.libreoffice.org/en/question/44174/how-to-select-entire-column-
> while-using-vlookup-function-in-calc/
> 
ACK
> 
> Also when using not the entire column, and using the formula generator
> (click the fx icon), Calc should automatically make the references for the
> corner cell to absolute references. 
> 
Objection!
> ...

A "clicked reference" should either be ALWAYS relative or ALWAYS absolute. Software shouldn't pretend to know in every cas what "The User" is actually needing/wanting. One who designes a formula should feel reliable for the reference cases used. 

Ceterum censeo: In other cases, in specific with regard to formulae, the same principle should be observed.
Comment 7 Yousuf Philips (jay) (retired) 2015-05-29 21:23:52 UTC
Spoke with moggi and he said this is a formula parsing problem.

The work around is to go into Tools > Options > Calc > Formula and change formula syntax from 'Calc a1' to 'Excel a1'.
Comment 8 Óvári 2015-05-30 06:18:48 UTC
(In reply to Yousuf (Jay) Philips from comment #7)
> Spoke with moggi and he said this is a formula parsing problem.
> 
> The work around is to go into Tools > Options > Calc > Formula and change
> formula syntax from 'Calc a1' to 'Excel a1'.

Unfortunately this does not work as intended as the following will highlight:
1. In cell A2 enter the formula: =SUM(B:B)
2. Delete row 4
3. The formula in cell A2 is now incorrectly: =SUM(B$1:B$1048575)

Subsequently, this fix is required to have feature parity with other office software solutions available.
Comment 9 raal 2015-06-03 13:36:17 UTC
*** Bug 91819 has been marked as a duplicate of this bug. ***
Comment 10 Eike Rathke 2015-06-16 16:25:13 UTC

*** This bug has been marked as a duplicate of bug 44419 ***